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Introduction

INTRODUCTION
The 164692 ER60 Scientific echo sounder application is designed
for fishery research and incorporates the following primary
features:
• Transceiver operation control
• Sensor input control
• Information display (echograms and numerical data)
• Data output and record control
• Replay of previously recorded data

Important notice

Windows, Windows NT and Windows XP® are either registered
trademarks or trademarks of Microsoft Corporation in the United
States and/or other countries.

Echo sounder software version

This manual complies to echo sounder software version 2.2.0.
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OPERATIONAL PROCEDURES
This chapter contains a number of specific procedures to be used
with your Simrad ER60 echo sounder.

Topics

Power on/off on page 11
Basic operation on page 13
Transceiver installation on page 15
Data recording and playback on page 16
Calibration on page 19
Noise measurements at sea on page 32
Multiplexer set-up on page 37
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Power on/off
Use the following procedures to switch the ER60 echo sounder
on and off.

Related topics

Log In on page 115
Exit on page 99
Transceiver Installation on page 156
Normal Operation on page 124
New Channel on page 122

How to switch power on
It is assumed that the echo sounder’s hardware and software are
properly installed and set up.
1 Switch power on.

• The location of the power switches are individually
assigned. The computer has its own power switch. The
transceiver(s) must be connected to separate power
supplies, and should have a remote power switch.

2 Observe the hardware test messages and operating system
start-up messages.

3 Start the ER60 program.
4 If the Login dialogue box appears, enter user name and

password.
5 Select Operation →Normal.
6 Once the echo sounder is running, start pinging by pressing

the “Start” button on the toolbar.

Figure 1 The “Start” button on the toolbar

How to set up transceiver channels
If no channels appear in the Normal Operation dialogue, observe
the following procedure.
1 Click Install →Transceiver to open the Transceiver

Installation dialogue.
2 Check that all frequency channels are properly installed.
3 Click Operation →Normal to open the Normal Operation

dialogue.
4 Check the operational mode for each of the installed

channels. Adjust as required.
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5 ClickWindow→New channel to open a new channel window.

How to switch power off
To switch off the ER60 echo sounder, observe the following
procedure.
1 Click File →Exit.
2 Allow the computer to close all the ER60 software

applications.
• If desired, ER60 can be restarted using the desktop icon.

3 Switch off the power on the General Purpose Transceiver
(GPT) and other peripherals (if any).

When the ER60 software has closed down, you need to close
down the computer as well.

12 164692/C
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Basic operation
This chapter presents a number of common procedures frequently
carried out on the ER60 echo sounder.

Related topics

Echogram view on page 48
Depth view on page 45
Echogram on page 84
Bottom Range on page 69
Surface Range on page 151
Normal Operation on page 124
Bottom Detection on page 67

How to change the echogram settings
To change the echogram settings:
1 Position the cursor in the Echogram view.
2 Click the right mouse button.
3 Click Echogram on the short-cut menu, and observe that

the Echogram dialogue opens.
4 Make the desired changes.
5 Click Ok.

How to change the range
To change the range:
1 Position the cursor in the Echogram view.
2 Click the right mouse button.
3 Click Range on the short-cut menu, and observe that either

the Bottom Range or the Surface Range dialogue opens
(depending on the current setting).

4 Make the desired changes.
5 Click Ok.

How to change the vertical resolution
The vertical resolution of the echogram increases with a shorter
pulse duration.
Example: A pulse duration of 1.024 millisecond gives a vertical
resolution of 19.2 cm, whereas a pulse duration of 0.256
millisecond gives a vertical resolution of 4.8 cm. If the vertical
distance between two echoes is less than this, the two echoes will
be shown as one.
Observe the following procedure to change the pulse duration:
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1 Click Operation →Normal, and observe that the Normal
Operation dialogue opens.

2 Set the desired pulse duration for each of the frequency
channels.

3 Click Ok.
A small value gives the best resolution, while larger values
provides you with a longer detection range.

How to define minimum and maximum
depth
Setting the minimum and maximum depth enables the echo
sounder to search for bottom lock.

Note

Setting both Minimum Depth and Maximum Depth to 0 m will
turn off bottom detection.

1 Position the cursor over the depth information in the Depth
view.

2 Click the right mouse button.
3 Click Bottom Detector on the short-cut menu, and observe

that the Bottom Detection dialogue opens.
4 Set minimum and maximum depth to the desired values.
5 Click Ok.
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Transceiver installation
Use the following procedures to install, modify or delete
frequency channels from the echo sounder setup.

Related topics

Transceiver Installation on page 156

Background
General Purpose Transceivers (GPT) physically connected to the
echo sounder’s ethernet interface are identified automatically by
the system. When you open the Transceiver Installation dialogue
box from the Install menu, a list will be provided. A single
frequency transceiver occupies one entry in the list. This entry
is identified as a Frequency Channel, and the line displays the
parameters for the channel. Entries in the frequency channel
list are shown in black, green, blue or red colour identifying its
current status.

How to install a channel
To install a channel:
1 Click Install→Transceiver, and observe that the Transceiver

Installation dialogue opens.
2 Click the desired entry (one of the black colour line

alternatives) in the Frequency Channel Selection list.
3 Assign a transducer by clicking a transducer name in the

Transducer Selection list.
4 Click Ok.

How to disconnect a channel
To disconnect a channel:
1 Click Install→Transceiver, and observe that the Transceiver

Installation dialogue opens.
2 Click the desired entry in the Frequency Channel Selection

list.
3 Select the alternative None in the Transducer Selection list.
4 Click Ok.
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Data recording and playback
Use the following procedures to install, modify or delete
frequency channels from the echo sounder setup.

Related topics

File Output on page 100
Replay on page 144

Background
You can set up the echo sounder to record unprocessed transducer
signals (sample data) and external sensor information onto files.
These files contain the necessary information to reconstruct the
situation during the real survey. The echo sounder program reads
these files during replay.

How to record raw data
Observe these procedures to record data.

Preparations

1 Click File →Output, and observe that the File Output
dialogue opens.

2 Click the Directory tab, and click the Browse button if you
wish to change the directory to which the files are stored.

3 Click the Raw Data tab to define how the raw data is to be
recorded.
• Save raw data: Start/stop recording of raw data.
• Range: Select the depth range to be recorded. This range,
referring to the transducer face, is independent of any
other range settings in the echo sounder.

• Echogram data: This is user defined excerpts of the
processed sample data (pixel data), ie the backscatter
value of the targets. The echograms are stored as time
tagged datagrams in separate files.

4 Click Ok to exit the dialogue.

Start and stop recording

Use either the tool-bar buttons or the Save raw data check box in
the File Output dialogue to start or stop recording of data.

Figure 2 The “Recording” buttons on the toolbar
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Note on size of stored raw data

The size of the raw data files stored depends on several
user selections. From these selections you may estimate
approximately the total amount of raw data stored in a given time
period for each installed channel using the following equation:

X = B M 24 3600
R 8

c T

where:
• X = Total amount of stored raw data in bytes for one channel
• B = 4 (Given by the resolution of the sample data)
• R = Selected range in meters (User defined)
• c = Sound speed in water in meters per sec (User defined)
• T = Pulse duration in seconds (User defined)
• M = Ping rate in ping per seconds (User defined)
• 24 = hours
• 3600 = seconds per hour
Thus, you can affect the amount of stored raw data by changing
e.g. the range, pulse duration, and ping rate settings.

How to play back raw data
Observe these procedures to play back data.

Playback single file

The playback is started as follows:
1 Click Operation →Replay, and observe that the Replay

dialogue opens.
2 Select the single file to be played.

• If no file is listed, click the Add button to select. Note
that only one replay file can be listed if this single file
shall be replayed.

3 Click Loop if you wish to loop through the selected file
endlessly.

4 Click Ok.
5 Click the “Play” button in the toolbar.

Figure 3 The “Play” button on the toolbar

Playback multiple files

The playback is started as follows:
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1 Click Operation →Replay, and observe that the Replay
dialogue opens.

2 Click the Add button to select playback files
• You can place any number of files in the list in the Replay
dialogue.

3 Click Loop if you wish to loop through the selected file
endlessly.

4 Click Ok.
5 Click the “Play” button in the toolbar.
Even though you only select one file in the Replay dialogue, the
ER60 will play through all of them in the same order as they are
listed. If the loop function is enabled, the playback will return to
the first file, and play through all of them one more time. This
will be repeated until the playback is stopped.
During playback, the ping rate is not limited by the speed of
sound in water. Hence, it is possible to select a higher ping rate
than during normal operation.

Playback including trawl datagrams

When you play back raw data, the Trawl dialogue on the Install
menu is unavailable. This means that although you play back the
data with the trawl datagrams intact, you may not be able to see
them. In order to rectify this, observe the following procedure
before you start the playback:
1 Click Install →Trawl
2 In the Trawl dialogue, set System to either Trawl, PI or

Ifremer according to the datagrams you wish to see.
3 Select manual parameters if required.

Note

If the distance from the vessel to the trawl is different from 0
(zero), you will need to enable the distance counter in the
Navigation dialogue.

4 Click Ok.
5 Start replay.
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Calibration
For acoustic surveys where accurate quantitative measurements
are required it is essential that the echo sounder is correctly
calibrated. It is a safe practice to perform the calibration before
and after the survey. If experiences over time show that no
adjustments are necessary, it may be appropriate to reconsider
the need for frequent calibrations. Simrad recommends that
calibration is performed at least once a year, and in areas with
different summer and winter condition at least twice a year.

Introduction
During calibration a reference target with known target strength
is lowered into the sound beam, and the measured target strength
is compared with the known target strength. If it is necessary
to adjust the echo sounder, this is performed automatically by
the ER60 calibration software. Since the echo sounder is digital
right from the receiver front end, no analogue gain adjustment
is required.
The reference target is normally a metal sphere. Simrad supplies
a variety of copper spheres, one for each frequency. The sphere
diameter is selected for minimum temperature dependence.

Preparations and transducer maintenance
The transducer is heavily exposed to fouling. Make sure that the
transducer face is painted after installation, and that the paint is
maintained whenever the vessel is in dry dock. Always use an
approved anti-fouling paint.
Depending on the environmental conditions where the vessel
operates, fouling must be removed from time to time. Failing to
do so will degrade the echo sounder performance. Use a soft
piece of wood and remove the fouling carefully. Afterwards, use
a very fine grade emery paper.

Note

Do not remove fouling with a metal tool or wire brush.
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Calibration procedures
This section holds the calibration procedures.

Topics

Check installation on page 20
Anchoring on page 21
Winches on page 22
Attaching the sphere on page 23
Lowering the sphere on page 24
Reference target on page 24
Calibration on page 25
Views on page 27
Data editing on page 29
Updating transducer parameters on page 30
Previously recorded data on page 30
Offline calibration on page 30

Check installation

1 Check that the ER60 and all the transceivers and transducers
are installed correctly, and that they are all fully functional.

2 Measure the water salinity and temperature between the
transducer and the sphere depth.

3 Calculate the average salinity and temperature values, and
enter these data in the Environment dialogue box.
• The sound velocity is automatically calculated by the
echo sounder.

• The corresponding absorption coefficient is calculated
by the echo sounder according to Francois & Garrison,
JASA December 1982.

• For additional information about the dialogue box, see
Environment on page 94.

Note

When you calculate the target strength (TS), you must use
the sound velocity at the sphere’s depth.

4 Use the ER60 to check that operation in Normal mode
functions properly for all transducers.
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Figure 4 Sound speed in water
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Figure 5 Sound absorption
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Anchoring

The following rigging description is to a great extent reproduced
from ICES report 144.
1 Find a location with calm and sheltered water.
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• Avoid areas with large differences in tidal height, as this
gives strong tidal current.

• Avoid areas near river mouths and harbours with heavy
traffic.

• An area with little or no fish present is favourable.
2 Ensure that the depth is sufficient for separation of sphere

and bottom echoes.
3 Pull a rope beneath the hull from one side of the vessel to

the other.
4 Anchor the vessel.
It is desirable to work in water as deep as possible, consistent
with maintaining a stable platform. Both bow and stern anchoring
or mooring is recommended.
If the vessel is anchored or moored only fore or aft, the wind
will cause it to drift sideways. If the current then attacks with a
different angle, it will make a bad situation even worse. If the
vessel is allowed to move sideways, or if the current runs abeam,
this will normally give larger variations in the echo sounder
performance. This results in poor and not reliable calibration
accuracy.

Winches

We recommend the use of winches to guide and steer the lines
to the sphere for its centring in the echo sounder beam. These
winches must be mounted to the deck railing in accordance with
detailed ship drawings.
1 Place the first winch in the transverse plane of the vessel

running through the transducer.
• If the transducer is mounted on one side of the keel, place
the first winch on the opposite side of the vessel.

2 Place the second and third winches on the same vessel side
as the transducer and at equal distances from the transverse
section containing the transducer and first winch.
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Figure 6 Rigging the vessel for sphere calibration
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Each winch must be provided with a long spool of 0.60 mm
diameter monofilament nylon line, which is marked with small
swivels at 5 m intervals, beginning 10 m from the loose end. The
purpose of the swivels is threefold:
• to unravel rotation of the nylon line
• to mark distances on the line
• to add weight so that the line sinks in water

Attaching the sphere

1 Locate the rope pulled beneath the hull before anchoring.
2 Use this rope to pull the line from the first winch beneath the

hull to the side with the second and third winches.
3 Attach the appropriate sphere, with affixed loop, to the three

suspension lines.
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For the smaller spheres it may be necessary to add a weight to
keep the sphere stable. This is done via a second line attached to
the three suspension lines. The length of the line must be at least
two pulse lengths, so that the echo from the additional weight
does not interfere with the sphere echo. Immerse the sphere
in a solution of dishwasher detergent and freshwater and lift it
overboard by the fastened lines without touching it. The soap
helps to eliminate air bubbles attached to the sphere.

Lowering the sphere

Lower the sphere beneath the vessel to the desired depth, for
example 25 m, which is determined roughly by counting the
swivels on each line.
The required depth is mainly determined by the transducer beam
width and the vessel geometry. The physical width of the beam,
which increases linearly with range, should be sufficiently great
so that the sphere echo is unaffected by the small movements to
which it is inevitably subjected.
In most cases calibration will be performed at depths larger than
10 m. However, the chosen depth should be limited to ensure
that it is possible to cover the entire beam. The minimal depth
must also be convenient with respect to the vessel geometry.
In particular, if the suspension lines do not hang freely, then
control of the sphere may be hindered by friction or possible
obstructions on the hull. Despite the number and variety of these
considerations, it is seldom difficult in practice to find a suitable
depth, which satisfies all of the above criteria.

Reference target

Simrad supplies copper spheres designed as reference targets for
the calibration of scientific sounders. Copper is selected because
it is a metal which can be made electrolytically with high purity.
The spheres are machined to the perfect spherical form with
great accuracy, and a nylon loop is attached. Except for 12 kHz,
49 kHz and 50 kHz, the sphere diameter is different for each
frequency in order to obtain a target strength with minimum
dependence of temperature (K. Foote 1983). A curve showing
the variation of the target strength follows each sphere.

Table 1 Copper spheres

Frequency (kHz) Diameter (mm) Target strength (dB)

12 45,0 –40,4

18 63,0 –34,4

27 42,0 –37,9

38 60,0 –33,6
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Table 1 Copper spheres (cont’d.)

Frequency (kHz) Diameter (mm) Target strength (dB)

49 45,0 –36,4

50 45,0 –36,2

70 32,1 –39,1

120 23,0 –40,4

200 13,7 –45,0

710 10,3 –50,5

Target strength calculated for sound speed 1490 m/s. The same
sphere is used for 49 and 50 kHz.

The curve for the 38 kHz sphere is given as an illustration.

Figure 7 Target strength of a 60 mm copper sphere
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Calibration

Only one frequency may be calibrated at a time.
Note

When you calculate the target strength (TS), you must use the
sound velocity at the sphere’s depth.

All the different combinations of pulse duration and transmitter
power for each frequency that will be used during normal
operation of the echo sounder must be calibrated. First, create a
well organised file directory for the calibration results.
Example:
c:\er60\calibration\2003\38kHz\0.256msec\
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The same structure can be repeated for the different pulse
duration for each frequency. When you save the calibration file,
create a file name that includes the current date and the current
output power. Save the information as a TXT file.
Example:
....\0.256msec\cal010603-2000w.txt

While the calibration takes place, we recommend that you also
collect a raw data file. Browse the file directory in the Store
dialogue box to locate the correct directory. The raw data file
name will be generated automatically, but you may specify a
prefix. The raw data file is used for replay.
The same procedure can be repeated for each of the installed
frequencies. Observe the following calibration procedure.
1 Click Operation →Ping control.
2 In the Ping Control dialogue, set Ping rate to Interval and

1 second.
• This can also be done from the toolbar.

3 Click Operation →Normal.
4 In the Normal Operation dialogue:

1 Select transceiver, and switch to Active mode.
2 Set the Transmit Power to the level you wish to

calibrate.
3 Choose the Pulse Duration you wish to calibrate.

5 Right-click in an echogram, select Range on the short-cut
menu, and set the range for one of the echogram views to
cover the range you wish to see.
• This range should include the depth range where you
expect to find the reference target.

6 Check that you see the reference target in the Single Echo
view.

7 Right-click in the Single Echo view corresponding to the
echogram to open the Single Target Detection dialogue box.

8 In the Single Target Detection dialogue, click the Calibration
button to start the calibration program, and to create a new
Calibration window.
• The calibration program allows you to record new
calibration data, or read previously recorded calibration
data.

9 In the Calibration window, click File →New to open the
Record dialogue and to start a new calibration.

10 Enter the following data in the Record dialogue box:
1 Transducer’s serial number
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2 Correct theoretical target strength (TS) for the reference
target

3 Allowed deviation from the TS for the reference target
• This is a window giving the limits for the system’s
acceptance of single target echoes coming from
fish. The closer to the correct reference target TS
the limits have been set, the more of the unwanted
fish echoes will be rejected. On the other hand, if
the echo from the reference target is too close to
one of the limits, the deviation has to be increased
before starting collecting data. This is because it
will always be a certain variation in TS values when
the reference target is being moved to cover the
complete beam.

4 Upper and lower depth limits for the target window
• A narrow window will have same effect as above,
reducing the possibility of detecting unwanted
echoes from fish.

5 Any comments you may wish to add to the calibration
file

11 Click OK when you have finished entering data.
The calibration program will now begin recording data.

Views

You will see two views in the Calibration window; a Plot view
and an Information view.
A vertical bar is shown on the left side of each view. A blue
colour indicates that the view is active, while gray colour
indicates a passive view. If you wish to print a view, or perform
other operations connected to it, you must make sure that the
desired view is active.
In the Plot view you will see recorded data plotted as blue and red
circles. Blue circles indicate TS values below the current beam
model, while red circles indicate values above the current beam
model. In the upper part of the Information view you will see
various information associated with recording of the calibration
data. Lines containing this information all begin with a #. Below
this information, recorded values for each new TS detection are
updated continuously during data recording.
1 Move the reference target slowly around to record a

sufficient number of data points (>100) evenly distributed
inside the beam. Make sure that a reasonable number of hits
are made close to the centre of the beam. This is important
in order to ensure a correct estimate for the Sa correction
parameter.
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2 While moving the target you should keep the reference target
within the depth limits you entered in the Record dialogue.

3 While moving the target and recording of data points stops,
the measured TS value may be outside the limits entered in
the Record dialogue.

4 Stop and restart recording as required by using the Stop/Start
command found in the Main menu. It is recommended to
stop collecting data if unwanted fish echoes are entering into
the depth window, and restart again when disappeared.

5 When you have finished data recording, click File→Save As
to open the Save As dialogue.

6 Choose the directory where you want the calibration file to
be saved, and enter a file name for your calibration file.

7 Click Save to finish.
The calibration program will now use two different models to fit
recorded data, a polynomial model and a beam model.
The Plot view will plot the model along with the recorded data
points. Blue circles indicate values below the model; red circles
indicate values above the model. The green circles close to
the centre axis indicate the points that have been used when
estimating the Sa Correction value.
In the View menu located on the menu bar you can control what
is shown in the Plot view. You can choose between results from
the polynomial model or the beam model. In the View menu you
can also choose the plot type for each of the two models. If
you choose the Polar command you will see a polar plot from
“above”. The other plot types are cartesian showing a slice
through the model. You may toggle between the plot types using
the space bar on your keyboard. The polynomial model is a
flexible function capable of modelling complex function shapes.
The polynomial model is only used to check in the Plot view
that the estimated polynomial model has the same shape as the
shape of the beam model. If the shape of the polynomial model
is very different from the shape of the beam model, this indicates
that either insufficient data have been collected, or some data
points may be associated with errors (broken cables or channel
wires mixed).
The beam model is the model actually used by the echo sounder.
The calibration program will adjust the parameters in the beam
model to minimise the RMS error calculated on the recorded data
points. The adjusted parameters, the RMS error, and the data
points having maximum and minimum deviation from the model
are shown in the Information view. The adjusted parameters
resulting from the beam model are the parameters, which can be
transferred to the echo sounder and used for the transducer during
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operation. Information on data deviation from the beam model
will indicate how well the beam model fit the recorded data. This
can be used to evaluate the validity of the recorded data points.
The data evaluation should start using the Plot view and the
polynomial model to check the shape of the polar plot. A circular
transducer should have a circular beam and an elliptic transducer
an ellipse, both with only insignificant offset angles. If a circular
transducer in the Plot view shows an ellipse with approximately
45 or 135 degrees axis, the reason may be one missing quadrant
in the transducer or one missing quadrant in the receiver. This
symptom should also give approximately 2 dB lower TS, i.e.
1dB lower transducer gain to compensate.
If a circular transducer in the Plot view shows an non circular
shape, and in addition substantial offset angles both athwart and
alongship, this indicates there may be something wrong in the
way the transducer is connected. In this case, you must select the
View menu and check the calibrated beamwidth, offset and gain
values. If one quadrant of the transducer is inversely connected,
the beamwidth will be approximately one degree too wide, the
offset angles will be approximately one degree off centre in both
directions and the calibrated gain can be in the order of 6 dB
lower than the default gain.
If two of the quadrants have been mixed up, the reference
sphere’s movements inside the beam will be incorrect. This can
be confirmed when the reference sphere is suspended in such a
way that you can move it in a specific direction. This direction
is either transversal or longitudinal in the transducer beam.
However, this is only possible if the split beam transducer has
been correctly installed.

Data editing

In both the Information and Plot views, you may perform data
editing in the sense of excluding or including an accepted single
echo detection. A left or right mouse click will act as a toggle
function for this editing. The model is completely recalculated
for each change.
In the Information view, a suspended single echo will be
identified with an asterisk (*) on the left side of the view.
The Plot view will draw an “empty” circle to indicate suspension
of the single echo entry.
The data deviation from the beam model should for a good
calibration give a RMS value less than 0.2 dB. If unwanted
echoes have been observed during data collection, these should
preferably be removed from the file. If, when collecting data, fish
swim into the layer that includes the reference target, then note
where in the file this happens, and delete these echoes before
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the beam data are updated. Data with large deviation from the
calculated curve are may be caused by poor acoustic conditions
or by back scattering objects other than the reference target.
Isolated echoes with large deviation from the calculated beam
pattern can be removed, but when a large amount of the collected
data diverge from the average, this indicates that the acoustic
conditions has been unfavourable. When the RMS value is in
between 0.2 and 0.4 dB, this indicates conditions is not perfect
but still acceptable. When the RMS value is higher than 0.4 dB
the calibration is poor, and should preferably be rejected and not
used for updating of the transducer parameters.

Updating transducer parameters

When you are satisfied with the calibration results you can use the
results to update your transducer parameters in the echo sounder.
1 In the Calibration window, click File→Update Beam Data to

perform this task.
Note

This is a serious operation, which will affect the transducer
installation parameters and will thus affect all future results to
be obtained using the current transducer and pulse duration.
Thus, to prevent accidentally use of this operation, you are asked
to confirm this operation.

The changes take effect automatically the next time you start
normal operations on the echo sounder.

Previously recorded data

The Calibration program also allows you to work with previously
recorded calibration data.
If you have used the ER60 to record raw data from a previous
calibration session you may operate the ER60 in replay mode
and perform the described calibration procedure as if the ER60
was operating in Normal mode. When operating in Replay mode
you can set the ping rate to maximum since this will not affect
the data quality.

Offline calibration

The calibration program may be run off-line without an
operational ER60. To start it, locate the file calibration.exe. If
you have performed a standard installation, this file is normally
found in the following path:
c:\program files\simrad\scientific\ek60\bin\calibration.exe

If you have a calibration file previously generated by the ER60
calibration program, you can import the file in the calibration
program.
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1 In the Calibration window, click File→Open.
2 Select the file you would like to import, and click Ok.
3 Examine and edit the previously recorded calibration data.
Edited data may be saved and you can update the transducer
parameters using the imported or edited calibration data. This
also enables you to use different calibration files from different
environmental conditions.
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Noise measurements at sea
The final result of the noise measurements should be a plot of the
acoustic noise in front of the transducer versus vessel speed. This
plot may be compared with similar plots for other transducers on
the same vessel, or plots from other vessels. It may thus serve
as an evaluation of the transducer location and the vessel noise
radiation. In addition, the noise plot may be a guide in choosing
the vessel speed during acoustic surveys. Since the propeller
pitch and revolutions per minute influence the noise level, it
is important to determine the most favourable combination of
these factors. Normally a slow rotation and a high pitch give
the lowest noise.

Basic guidelines
The noise measurements should take place at least one nautical
mile off shore, away from other ship traffic and with calm sea.
The water depth should be 200 m or more to avoid propeller
noise reflections from the seabed. The important parameter to
evaluate is the noise directly radiated from the propeller into the
transducer. This noise should be measured at different vessel
speeds, from 0 to maximum speed in steps of 1 or 2 knots. The
vessel’s course must be kept steady during these measurements.
The noise level for 38 kHz with the vessel in deep water and
without sailing should be approximately -145 dBW or lower.
Minor increase can be expected for higher and lower frequencies.
When the speed increases the noise level will normally increase
as well, but a properly designed vessel should only show a modest
increase and mainly when approaching the maximum speed.
With the settings specified below, the printer may be used to
produce an echogram as documentation for all the installed
transceivers. With some experience it should be possible to reveal
the acoustic noise source from looking at the echogram. Typical
sources may be propeller cavitation, small damages on the
propeller blade, the machinery, or flow-noise. It is a good routine
to save the echogram for comparison with later recordings. The
propeller noise will often be revealed by the pattern shown on the
echogram. The distance between succeeding high intensity fields
in the pattern should correspond with the number of propeller
blades and the rotation speed.
Electrical noise from the ship’s mains supply and electrical
motors will give a pattern with distinct lines on the echogram
determined by the frequency of the mains supply. By choosing a
convenient range for the echogram, the distance between the lines
will give a good indication of the frequency causing the noise.
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Noise speed tests should be performed after all the frequencies
have been calibrated. All the frequencies can be measured
simultaneously. Thus, you should install all transceivers in ER60.

Noise measurement procedure
Observe the following procedure.

Initial set-up

1 Click Install→Transceiver, and observe that the Transceiver
Installation dialogue opens.

2 Ensure that all the transceivers are installed.
3 Click Operation →Normal, and observe that the Normal

Operation dialogue opens.
4 Set the following parameters:

• Passive mode
• Maximum transmit power
• Same pulse duration as used during the calibration
• 0.0 m transducer depth

5 Click Operation →Ping Control, and observe that the Ping
Control dialogue opens.

6 Set the following parameters:
• Maximum ping rate
• Switch off all external triggering

7 Right-click in the Echogram view, and select Echogram on
the short-cut menu to open the Echogram dialogue.

8 Set the following parameters:
• Surface reference
• Sv backscatter

9 Right-click in the Colour Scale view, and select Colour Scale
on the short-cut menu to open the Colour Scale dialogue.

10 Set the following parameters:
• Minimum level -100 dB (chosen to give a reasonable
ping rate)

• Maximum level -64 dB
11 Right-click in the Echogram view, and select Range on the

short-cut menu to open the Surface Range dialogue.
12 Set the following parameters:

• Start relative surface: 0 m
• Select a range that will provide a noise recording with at
least two or three colours on the echogram.
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13 Right-click in the Echogram view, and select Bottom
Detection on the short-cut menu to open the Bottom Detection
dialogue.

14 Set the following parameters:
• Bottom detection = 0.0 m
• This disables the bottom detection algorithm. This
algorithm reduces the ping rate in passive mode, and it
is not required.

15 Click Output →File, and observe that the File Output
dialogue opens.

16 Set the following parameters:
• Same range as in the echogram
• 0 Mb maximum file size

17 Start the echo sounder.

Increasing speed

Start the test loop with vessel speed 0 knots.
1 Make a short echogram recording, find the noise level in the

Numerical view, and note down the values.
2 Increase the vessel speed with 1 or 2 knots, and wait until

the speed is stable.
3 Repeat the loop until the vessel has reached maximum speed.

Decreasing speed

Start with maximum vessel speed.
1 Start echogram recording
2 Disengage the propeller as quickly as possible to allow the

vessel to slow down by itself.
3 Use the annotation or event features to tag each 1 or 2 knots

speed decrease.
4 Stop the echogram recording once the vessel has stopped.
If the noise decreases quickly towards the same level as at 0
knots when the propeller has been disengaged, this means that the
propeller mainly generates the noise. If the noise at decreasing
vessel speed is more or less equal to the noise level at increasing
speed, the noise is probable flow-noise. Usually the noise is
a combination of both.
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Test results
Print this table, and use it to fill in the measured values.

Engine revolutions (rpm)

1 2 3 4 5 6 7 8 9

Propeller revolutions (rpm)

Propeller pitch

(knots)Vessel speed

Estimated noise level (dB*)

Estimated noise level (dB**)

Engine revolutions (rpm)

10 11 12 13 14 15 16 17 18

Propeller revolutions (rpm)

Propeller pitch

Vessel speed (knots)

Estimated noise level (dB*)

(*) Estimated noise level measured in dB re 1W

(**) measured in dB re 1 Pa / HzμEstimated noise level

Estimated noise level (dB**)

(CD010015A)

Evaluation
If the noise is substantial and mainly caused by the propeller,
the procedure should be repeated with different combinations
of pitch and propeller speed if possible, to determine the most
favourable settings.
The echogram recording will give you immediate information
regarding the maximum possible detection range for the chosen
settings. The light grey colour on the echogram relates the depth
where the noise will mask the useful echo from biomass.
In order to allow the echogram to indicate the depth where the
selected back-scattering is reached, make the following settings:
• In the Echogram dialogue box, set Backscatter = Sv
(20 Log TVG).

• In the Colour Scale dialogue box, set the desired lower Sv limit.
Example: If the desired lower Sv limit is -70 dB, and at the same
time a signal-to-noise ration of 10 dB is required, the setting in
the Colour Scale dialogue box for 20 log TVG must be -80 dB.
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The depth where the light grey colour appears on the echogram
then indicates the maximum depth where the desired Sv limit is
obtained with a signal-to-noise ratio of 10 dB.
When you select Backscatter = Sp (40 log TVG) in the Echogram
dialogue to record single object target strength, the desired lower
TS limit has to be set in the same way as above.
Example: If the desired lower TS limit is -50 dB, and at the same
time a signal-to-noise ratio of 10 dB is required, the setting in the
Colour Scale dialogue box for 40 log TVG must be -60 dB. The
depth where the light grey colour appears on the echogram then
indicates the maximum depth where the desired lower TS limit is
obtained with a signal-to-noise ratio of 10 dB.
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Multiplexer set-up
Use the following procedures to connect the multiplexer unit to
the echo sounder transceiver, and to enable it for operational use.
Technical information on page 38

Related topics

Transceiver Installation on page 156

How to connect the multiplexer
The multiplexer unit consists of a single metal box with two
cables. Both cables are terminated with plugs. Observe the
following procedure.
1 Switch off the echo sounder system.
2 Connect the cable with the transducer plug to the transducer

socket on the echo sounder transceiver.
3 Connect the cable with the D-Connector to the Auxiliary

socket on the echo sounder transceiver.
4 Makes sure that the two transducers are properly connected

to the multiplexer unit.
5 Power up the echo sounder system.

How to set up the transceiver
In order to put the multiplexer to use, observe the following
procedure.
1 Start up the echo sounder.
2 Click Install→Transceiver, and observe that the Transceiver

Installation dialogue opens.
3 Click to select a valid frequency channel, and make sure that

a transducer is shown under Transducer Selection.
4 In the Multiplexer Installation list, click Mux-2.
5 In the confirmation dialogue, click Yes to acknowledge the

choice.

6 In the Transceiver Installation dialogue, click Ok.
7 In the second confirmation dialogue, click Yes to

acknowledge the choice.
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8 In the restart dialogue, click Ok.

9 Click Operation→Exit to close the echo sounder application.
10 Restart the ER60.

Technical information
The use of the two transducers connected to the multiplexer is
controlled by the Alarm output (pin 11) on the General Purpose
Transceiver (GPT) Auxiliary connector.
• The alarm output goes “low” (0 V) approximately 10
milliseconds prior to transmission on channel X–1.

• The alarm output goes “high” (5 V) approximately 10
milliseconds prior to transmission on channel X–2.
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DISPLAY VIEWS
This chapter provides a brief overview of the information
displayed by the Simrad ER60, and how it is organised.

Topics

Display organisation on page 40
Main menu on page 41
Toolbar on page 42
Status bar on page 43
Channel windows on page 44
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Display organisation
The ER60 display is organised as follows (from top):
• Main menu
• toolbar
• A number of Channel Windows
• Status bar
A display with three channels windows (operating three echo
sounder frequencies simultaneously) is shown as an example.

Figure 8 Display example
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Main menu
The ER60 main menu is located at the top of the echo sounder
window.

Figure 9 Main menu

To operate, click on the menu name and observe the drop-down
menu. Select a new item on the drop-down menu by clicking
on the command.
Commands shown with light grey colour are unavailable in the
present configuration or operational mode.
A detailed description of the commands available from the main
menu is given in the Reference section.

Related topics

Main menu on page 53
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Toolbar
The ER60 toolbar is located directly underneath, or next to the
main menu. A number of dedicated buttons allow for easy access
to the most frequently used functions.

Figure 10 Toolbar, easy operation

Two toolbars may be applied, Normal operation and Easy
operation. The toolbar selection is made by the Toolbar command
on the View menu. Note that Normal operation is not available
during replay.

Figure 11 Tool bar, normal operation

The functions (from left) and their equivalent dialogue buttons
and controls are listed in the table below.

Table 2 Easy operation toolbar

Tool bar button Equivalent Dialogue box

Start pinging Start Ping control

Perform single ping Single step Ping control

Stop pinging Stop Ping control

Set ping rate Ping rate Ping control

Start raw data recording Save raw data File output

Stop raw data recording Save raw data File output

Initiate annotation Annotation text input Annotation

Generate event — Annotation

Table 3 Normal operation toolbar

Tool bar button Equivalent Dialogue box

Select channel — —

Select mode Mode Normal Operation

Related topics

Toolbars on page 154
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Status bar
The ER60 Status bar is located at the bottom of the display. It
presents messages from the echo sounder system as well as a
warning field on the right hand side.

Figure 12 Status bar example

The status bar can be enabled or disabled with the Status bar
choice on the View menu, and set up by clicking the right mouse
button while the cursor is located within the status bar borders.
When all information has been enabled, and if the relevant
sensors have been connected to the echo sounder, the status bar
will provide the following information (from left):
• Current messages
• Current vessel pitch in degrees
• Current vessel roll in degrees
• Current vessel heave in meters
• Event number
• Current heading
• Current vessel speed in knots
• Distance in nautical miles or meters
• Geographical position
• Recording status
• Current date and time
• Warning messages
The Warnings field on the far right side of the status bar is a
button. When a warning has been issued, the button will be lit
with a colour and a text indicating the nature of the message. To
investigate further, click the button.

Related topics

Configure Statusbar on page 77
Warnings on page 165
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Channel windows
The ER60 channel window is the main information bearer on
the echo sounder display. One channel window is provided for
each operational frequency, and you can have many channel
windows open simultaneously. Each channel window contains
the following views:
Depth view on page 45
Single target position view on page 46
Single target histogram view on page 47
Echogram view on page 48
Scope view on page 49
Colour scale view on page 50
Numerical view on page 51
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Depth view
The Depth view comprises the horizontal view directly below the
toolbar. The view displays the current depth.

Figure 13 Depth view
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If you click the right mouse button with the cursor position
within this view, a dedicated short-cut menu will appear. If you
press the middle mouse button, the Bottom Detection dialogue
box will open.

Related topics

Depth short-cut menu on page 57
Bottom Detection on page 67
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Single target position view
The Single target position view is normally located in the top
left corner.

Figure 14 Single target
position view
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This view shows the position within the beam of the
detected single echoes for the current ping (largest
circles) and the three previous pings (smaller circles),
all in the active layer. The colours used to display
this information are determined from current target
strength (TS) value and the settings in the colour
scale.
If you place the cursor inside the view, a small yellow
label will appear to give you a detailed read-out of
certain information. The Tooltip dialogue defines
which information that will be shown. If you click
the right mouse button with the cursor position within
this view, a dedicated short-cut menu will appear. If
you press the middle mouse button, the Single Target
Detection dialogue box will open.

Related topics

Single Target Position short-cut menu on page 57
Tooltip on page 155
Single Target Detection on page 148
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Single target histogram view
The Single target histogram view is normally located in the
bottom left corner of the display presentation

Figure 15 Single target
position view
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The histogram plot shows a visualisation of the
target strength (TS) distribution for the single echoes
detected in the Echogram view. The colours used
to display this information are determined from the
current target strength (TS) value and the settings in
the colour scale. The statistics are based on the active
layer and the current calculation interval.
If you place the cursor inside the view, a small yellow
label will appear to give you a detailed read-out of
certain information. The Tooltip dialogue defines
which information that will be shown. If you click
the right mouse button with the cursor position within
this view, a dedicated short-cut menu will appear. If
you press the middle mouse button, the Single Target
Detection dialogue box will open.

Related topics

Single Target Histogram short-cut menu on page 57
Tooltip on page 155
Single Target Detection on page 148
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Echogram view
The Echogram view will normally dominate each channel
window on the echo sounder display.

Figure 16 Echogram view

(CD010012E)

The echogram contains information about
the acoustical values. The settings in
the colour scale is used to present the
information. If you place the cursor inside
the view, a small yellow label will appear
to give you a detailed read-out of certain
information. The Tooltip dialogue defines
which information that will be shown. If
you click the right mouse button with the
cursor position within this view, a dedicated
short-cut menu will appear. If you press
the middle mouse button, the Echogram
dialogue box will open.

Related topics

Echogram short-cut menu on page 58
Echogram on page 84
Tooltip on page 155

48 164692/C



Display views

Scope view
The Scope view is normally located on the right side of the
Echogram view.

Figure 17 Scope view

(CD010012F)

The Scope view provides a logarithmic oscilloscope
visualization of the last ping. The presentation corresponds
to the current settings in the Echogram view. The view
draws a range of horizontal symmetrical colour lines. The
distance from the vertical centre axis and the line colour
reflects the received echo scatter.
If you place the cursor inside the view, a small yellow
label will appear to give you a detailed read-out of
certain information. The Tooltip dialogue defines which
information that will be shown. If you click the right
mouse button with the cursor position within this view, a
dedicated short-cut menu will appear.

Related topics

Scope short-cut menu on page 59
Tooltip on page 155
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Colour scale view

Figure 18 Color
scale view

(C
D

0
1

0
0

1
2

G
)

The Colour scale view is normally located on the left side of
the Echogram view.
The Colour scale view visualizes the mapping of echo strength
into one out of 12 colours, light blue for weak signals and
dark brown for strong signals. Basically, each discrete colour
represents a 3 dB range of echo signal strength implying that
the next colour is selected every time the echo strength doubles.
However, as the number of colours can differ, and dedicated
colour schemes can be used, this is not necessarily correct. A
high numeric TVG value displays weak echo signals properly
while the stronger signals saturate into dark brown colour. A
low numeric value displays strong echo signals properly. Weak
signals below the lower limit of the colour scale are not displayed
(the display background colour is used).
If you place the cursor inside the view, a small yellow label will
appear to give you a detailed read-out of certain information. The
Tooltip dialogue defines which information that will be shown. If
you click the right mouse button with the cursor position within
this view, a dedicated short-cut menu will appear. If you click the
middle button, the Colour Scale dialogue box opens.

Related topics

Colour Scale short-cut menu on page 59
Colour Scale on page 74
Tooltip on page 155

50 164692/C



Display views

Numerical view
The Numerical view is normally located on the far right side
of the display.

Figure 19 Echogram view

(CD010012H)

The Numerical view provides listing with
all the various parameters applicable for the
current mode and operation. The following
lists are available:
• Transducer: Typical specifications for the
active transducer

• Transceiver: Typical specifications for the
transceiver

• Environment: Displays the current
read-out from the active sensors

• Layers: Current parameters from the
active layers

If you click the right mouse button with the
cursor position within this view, a dedicated
short-cut menu will appear. On the short-cut
menu, you can open the Numerical View
dialogue, which allows you to define the
contents of the Numerical view.

Related topics

Numerical short-cut menu on page 60
Numerical View on page 126
Tooltip on page 155
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MENU SYSTEM
Menu navigation employed by the Simrad ER60 Scientific echo
sounder is similar to other Windows-based software. Main menu
topics located in the menu bar at the top of the window provide
access to drop-down menus. Menu choices that are shown in grey
are not available for the current operation or operational mode.
Several parameters are also available using short-cut menus
accessed by clicking the right mouse button. For more specific
menu information refer to the menu descriptions listed below.

Topics

Main menu on page 53
Short-cut menus on page 57
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Main menu
The ER60 main menu is located at the top of the echo sounder
window.

Figure 20 Main menu

To make a choice, click on the menu name and observe the
drop-down menu. Select a new item on the drop-down menu
by clicking on the command.

Operation menu
The Operation menu allows you to control the main operational
mode (Normal or Replay).

Figure 21 Operation menu

The following options are available:
Normal Operation on page 124
Replay on page 144
Ping Control on page 128
Data Source on page 80
Log In on page 115
Log Out on page 116
Exit on page 99

View menu
The View menu allows you to toggle the presence of the toolbar
and the status bar.

Figure 22 View menu
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The following options are available:
Toolbars on page 154
Status bar on page 150

Options menu
The Options menu allows you to define certain general
parameters, such as tool tip contents and presentation colours.
You are also allowed to save your current settings.

Figure 23 Options menu

The following options are available:
Colours on page 76
Tooltip on page 155
Calculation Interval on page 70
Load Settings on page 114
Save Settings on page 146

Install menu
The Install menu allows you to define the setup conditions for
your echo sounder.

Figure 24 Install menu

The following options are available:
Transceiver Installation on page 156
Navigation on page 118
Motion on page 117
Trawl on page 160
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Environment on page 94
Annotation on page 65
Remoting on page 139
Users and Passwords on page 163
Port Management on page 130

Output menu
The Output menu allows you to define the configuration of the
output data from the echo sounder.

Figure 25 Output menu

The following options are available:
File Output on page 100
Ethernet Output on page 97
Depth Output on page 83

Window menu
TheWindow menu allows you to open new channel windows and
control the arrangement of the windows.

Figure 26 Window menu

The following options are available:
New Channel on page 122
Cascade on page 72
Tile on page 153
Open All on page 127
Close All on page 73
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Help menu
The Help menu allows you to access the on-line help and to
check the current ER60 software version.

Figure 27 Help menu

The following options are available:
Contents on page 79
About on page 63
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Short-cut menus
The short-cut menus are accessed with the right mouse button
when the cursor is located in any of the views. Various menus
are provided depending on the current view. To make a choice,
click on the menu name and observe the drop-down menu. Select
a new item on the drop-down menu by clicking on the command.

Depth short-cut menu
The Depth short-cut menu allows you to control the properties of
the Depth view. It also provides common functionality related to
printing and window configuration.

Figure 28 Depth short-cut menu

The following options are available:
Bottom Detection on page 67
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108

Single Target Position short-cut menu
The Single Target Position short-cut menu allows you to control
the properties of the Single Target Position view. It also
provides common functionality related to printing and window
configuration.

Figure 29 Single Target Position short-cut menu

The following options are available:
Single Target Detection on page 148
Colour Scale on page 74
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108

Single Target Histogram short-cut menu
The Single Target Histogram short-cut menu allows you to control
the properties of the Single Target Histogram view. It also
provides common functionality related to printing and window
configuration.
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Figure 30 Single Target Histogram short-cut menu

The following options are available:
Histogram on page 109
Single Target Detection on page 148
Colour Scale on page 74
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108

Echogram short-cut menu

The Echogram short-cut menu allows you to control the
properties of the Echogram view. It also provides common
functionality related to printing and window configuration.

Figure 31 Echogram short-cut menu

The following options are available:
Echogram on page 84
Horizontal Axis on page 110
Range on page 138
New Layer on page 123
Layer Properties on page 112
Delete Layer on page 82
Print on page 135
Print Preview on page 136
Configure Window on page 78
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Hide View on page 108

Scope short-cut menu
The Scope short-cut menu provides common functionality related
to printing and window configuration.

Figure 32 Scope short-cut menu

The following options are available:
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108

Colour Scale short-cut menu
The Colour Scale short-cut menu allows you to control the
properties of the Colour Scale view. It also provides common
functionality related to printing and window configuration.

Figure 33 Colour Scale short-cut menu

The following options are available:
Colour Scale on page 74
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108
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Numerical short-cut menu
The Numerical short-cut menu allows you to control the
properties of the Numerical view and the current layers. It also
provides common functionality related to printing and window
configuration.

Figure 34 Numerical short-cut menu

The following options are available:
Numerical View on page 126
New Layer on page 123
Layer Properties on page 112
Delete Layer on page 82
Print on page 135
Print Preview on page 136
Configure Window on page 78
Hide View on page 108
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REFERENCES
This chapter contains reference information about dialogue boxes
and parameters.

Topics

Alphabetical list of dialogue boxes and functions on page 61
Dialogue box and functions descriptions on page 63

Alphabetical list of dialogue boxes and functions
This section provides an alphabetical list of all the dialogue
boxes.
About on page 63
Add User Account on page 64
Annotation on page 65
Bottom Detection on page 67
Bottom Range on page 69
Calculation Interval on page 70
Cascade on page 72
Close All on page 73
Colour Scale on page 74
Colours on page 76
Configure Statusbar on page 77
Configure Window on page 78
Contents on page 79
Data Source on page 80
Delete Layer on page 82
Depth Output on page 83
Echogram on page 84
EK500 Datagram on page 90
Environment on page 94
Errors on page 96
Ethernet Output on page 97
Exit on page 99
File Output on page 100
HAC Datagram on page 106
Hide View on page 108
Histogram on page 109
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Horizontal Axis on page 110
LAN Port Setup on page 111
Layer Properties on page 112
Load Settings on page 114
Log In on page 115
Log Out on page 116
Motion on page 117
Navigation on page 118
New Channel on page 122
New Layer on page 123
Normal Operation on page 124
Numerical View on page 126
Open All on page 127
Ping Control on page 128
Port Management on page 130
Port Monitor on page 133
Print on page 135
Print Preview on page 136
Remoting on page 139
Replay on page 144
Save Settings on page 146
Serial Port Setup on page 147
Single Target Detection on page 148
Status bar on page 150
Surface Range on page 151
Tile on page 153
Toolbars on page 154
Tooltip on page 155
Transceiver Installation on page 156
Transducer Parameters on page 159
Trawl on page 160
User Properties on page 162
Users and Passwords on page 163
Warnings on page 165
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Dialogue box and functions descriptions
This section provides detailed descriptions of the dialogue boxes
and parameters.

About
The About function is accessed from the Help menu.

Purpose

The current ER60 software version and other related information
is provided here.

Press OK to close the dialogue box.
Note that the software version displayed in this dialogue box
should match the software version described in this publication.
The current software version described here is 2.2.0..
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Add User Account
The Add User Account dialogue box is accessed from the Users
and Passwords dialogue.

Purpose

This dialogue is used to enter user information when a new user
is added to the program. The user must be assigned an access
level. These are described in the User and Passwords dialogue
box description.

Use

Click Install→Users and Passwords. Click Add to add a new user.

Related topics

Users and Passwords on page 163
User Properties on page 162
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Annotation
The Annotation dialogue box is accessed from the Install menu.

Purpose

This dialogue allows you to add annotations to the data. The
annotations defined are stored with the raw data as annotation
datagrams. Annotations are displayed on the echogram if this
feature is enabled in the Echogram dialogue, and also included
on the status bar. Annotations can only be added during normal
operation.

Use

Click Install→Annotation. Add annotation, and click OK.
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Parameters

The Annotation dialogue holds four parameter fields.

Manual

Text input: Click this button to enter a free text string. The text
is written to the echogram once you click Ok in the Annotation
Text Input dialogue.

NMEA

Port: This function enables NMEA Annotation datagrams to be
imported on the chosen port.
Setup: Click to set up the communication parameters for the
chosen port. Depending on the port you have chosen, the LAN
Port Setup or Serial Port Setup dialogue will open.

Event

This function initiates annotation datagrams whenever an event
occur. Events may be triggered by external devices, set by a
timer, or initiated by clicking the Event icon on the toolbar.
Number: All events are identified with a number. This number
can be included in the annotation string. Using this feature, you
can manually select the next number to be used, and you can
choose to have the number series increase or decrease.
Text: Use this feature to select which items to be included in the
event generated annotation string.
Timer: Set a time period for automatic generation of events.
Triggering from external devices are made using pins 10 and 19
on the Auxiliary connector on the General Purpose Transceiver
(GPT). Refer to the Instruction Manual.

Last annotation

This text box automatically displays the latest annotation text
provided.

Related topics

LAN Port Setup on page 111
Serial Port Setup on page 147
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Bottom Detection
The Bottom Detection dialogue box is accessed from the Depth
short-cut menu.

Purpose

This dialogue is used to set the parameters for the bottom
detection algorithm. Note that only one set of bottom detector
parameters are valid for a frequency channel. This means that
changes made in this dialogue will have effect on the bottom
detector settings for all depth views for the same frequency
channel!

Use

Right-click in the Depth view to open the Depth short-cut menu,
then click Bottom Detection. Use the sliders or the spin boxes to
choose minimum and maximum depths.

Parameters

Minimum Depth: The bottom detector starts the search for the
bottom echo at this depth. The detector will fail in shallow
water if you select a too large depth value, and the tail of the
transmitting pulse or a large school of fish may cause problems if
a too small value is set.
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Maximum Depth: The search for the bottom echo extends down
to this depth whenever bottom track is lost. Enter a slightly larger
depth value than the deepest spot you expect to visit in order to
avoid annoyingly long ping intervals every time bottom track is
lost. A depth value of 0 disables the bottom detector.
Backstep Min. Level: After the estimated depth of the bottom
detector, the detected depth is automatically adjusted by stepping
back according to the value of the setting you have chosen. This
allows the echo sounder to verify that the correct bottom depth
has been located. If the value you enter is too large (close to 0 dB)
the adjustments will be very small. The default value is -50 dB.

Related topics

Depth short-cut menu on page 57
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Bottom Range
The Bottom Range dialogue box is accessed from the Echogram
short-cut menu.

Purpose

This dialogue is used to specify the vertical depth range for the
Echogram view.

Use

Right-click in the Echogram view to open the short-cut menu.
Select Range from the menu. Make the necessary adjustments.

Surface or Bottom?

The dialogue title and the range settings will be surface related
if the dialogue is opened while the echogram displays a surface
referenced echogram.
The dialogue title and the range settings will be bottom related
if the dialogue is opened while the echogram displays a bottom
referenced echogram.

Parameters

Refer to the descriptions for the Surface Range dialogue.

Related topics

Surface Range on page 151
Echogram view on page 48
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Calculation Interval
The Calculation Interval dialogue box is accessed from the
Options menu.

Purpose

This dialogue box is used to define how often the echo sounder
program will perform certain calculations.
Several parameters in the echo sounder are only calculated once
for a set interval. This interval can be any value for distance,
time or ping. Use the settings in this dialogue to define each of
these three interval factors. A vertical line is displayed in the
echogram views whenever a new calculation interval is started.

Use

Click Options →Calculation Interval. Choose if the calculation
interval shall be based on distance, time or number of pings.
Choose the interval and the unit accordingly using the appropriate
spin boxes.

Parameters

The dialogue box allows you to set up the calculation frequency
depending on distance, time or ping.

Distance

Distance: Check this box to perform calculations based on sailed
distance.
Interval: Select distance interval in the spin box.
Units: Select distance units (nautical miles or meters) in the
drop-down menu.

Time

Time: Check this box to perform calculations based on time.
Interval: Select time interval in the spin box.
Units: Select time units (hours. minutes or seconds) in the
drop-down menu.
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Ping

Ping: Check this box to perform calculations based on number of
pings.
Interval: Select number of pings between each calculation in
the spin box.

Related topics

Numerical view on page 51
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Cascade
The Cascade function is accessed from theWindow menu.

Purpose

This command is used to display a new channel window. This
can either be a new frequency channel, or a new view of an
existing frequency channel.

Use

This function is identical to the common function available in the
operating system. The active windows are presented in cascade;
that is partly on top of each other with the top bar shown.

Related topics

New Channel on page 122
Close All on page 73
Tile on page 153
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Close All
The Close All function is accessed from theWindow menu.

Purpose

Use this command to close all open windows.

Open new windows

To create a new window, click New channel on theWindow menu.
To open all existing windows, click Open All on the Window
menu.

Related topics

New Channel on page 122
Open All on page 127
Cascade on page 72
Tile on page 153
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Colour Scale
The Colour Scale dialogue box is accessed from the Single Target
Position, Single Target Histogram and Colour Scale short-cut
menus.

Purpose

The purpose of this dialogue box is to change the dynamic
range of the colour scale. The total number of colours used
in the presentation will be distributed between the minimum
and maximum levels identified in this dialogue. Values above
maximum level are shown using the “maximum level” colour,
while values below are shown with the background colour.

Use

Right-click in the Single Target Position, Single Target Histogram
or Colour Scale views to open the short-cut menu. Click Colour
Scale on the menu, and make the necessary adjustments.
Note

Do not confuse this dialogue with the Colours dialogue!

20 or 40 log

When the dialogue is launched from the Single Target Position
and the Single Target Histogram views, the colour scale
represents colour mapping for the 40Log TVG function. This
TVG function is always used for target strength estimation for
single targets. When the dialogue is launched from the Colour
Scale view, the TVG function depends on which acoustic variable
is chosen for display on the corresponding Echogram view. This
is because the colour scale view represents the colour mapping
for the Echogram view. The TVG functions can be either No,
20Log, or 40Log.
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Parameters

Min. level / Max. level: Use the spin boxes or sliders to set
the levels. Altering the maximum or minimum levels will
automatically adjust the colour step.
Colour step: Use this setting to define the range in dB each colour
will cover. Altering the colour step will automatically adjust the
maximum level.
Apply to all: Check this box to make the chosen settings apply to
all views.

Related topics

Colour scale view on page 50
Single target histogram view on page 47
Single target position view on page 46
Colours on page 76
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Colours
The Colours dialogue box is accessed from the Options menu.

Purpose

This dialogue is used to set colour parameters for the echo
sounder program.
Do not confuse this dialogue with the Colour Scale dialogue!

Use

Click Options→Colours, and make the necessary changes.

Parameters

The dialogue box holds three parameter fields.
No of colours: Set the number of colours to use in the display
presentations, 12 or 64.
Colour scale: Select the desired colour scale from the drop-down
list. Note that all colour scales except Smooth Echosounder
require that the number of colours is set to 64.
Palette: Select the colour palette for the echo sounder. This is a
personal choice based on the ambient light conditions. Note that
all the colours on the ER60 computer -. even other programs
running on the computer - are affected!
Note that you can also change the colour palette by right-clicking
on the Windows desktop, and then selecting Properties on the
short-cut menu. This will open the standard Display Properties
dialogue box, and you can make your choices on the Themes tab.
If you then enable a new palette from the ER60 Colours dialogue,
this choice will override the operating system setting.

Related topics

Colour Scale on page 74
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Configure Statusbar
The Configure Statusbar dialogue box is accessed when you click
the right mouse button on the Status bar.

Purpose

This dialogue is used to select which sensor information to
display on the Status bar.

Figure 35 Status bar example

Use

Position the cursor over the Status bar, and right-click to open the
dialogue. Check the boxes to enable or disable the information
you wish to see.

Related topics

Status bar on page 43
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Configure Window
The Configure Window dialogue box is accessed from all the
short-cut menus.

Purpose

This dialogue is used to define which views to show in the active
window.

Use

Right-click in any view to open the Depth short-cut menu, then
click Configure Window. Use the check boxes to show or hide
views in the window. Hiding a view does not disable it. This
means that all data for this view are still collected while the view
is hidden.
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Contents
The Contents function is accessed from the Help menu.

Purpose

Use this option to open the first page of the context sensitive
on-line help system.
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Data Source
The Data Source dialogue box is accessed from the Operation
menu.

Purpose

This dialogue box is used to select where the echo sounder
program shall obtain its data from. It can be used to connect to
an echo sounder program running on a remote computer. This
means that any computer on the network running the ER60
software can connect to the echo sounder computer and run the
sounder independently.

Use

The dialogue displays a list of echo sounder programs running on
the network to which the ER60 Processor Unit is connected.
If the Processor Unit is not connected to other echo sounder
programs, the list will only contain one entry. This single entry is
the echo sounder program running on the local processor unit.
You will not be able to perform installation operations (e.g.
transceiver and sensor installation) on other entries than the local
echo sounder program.
To perform operations on an entry in the list, the entry must be
highlighted (selected). To do this, click once on the entry to
select it.

Parameters

The Data Source dialogue box contains a list of data sources as
well as a limited number of buttons.

Data source parameters

The list holds the name and parameters for the current data
sources.
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Name: This column displays the installation name of the echo
sounder program entry. An asterisk (*) in front of an entry means
that this entry is currently selected data source. Only one entry
can be selected at a time. The installation name is defined in
the Remoting dialogue.
Description: This column displays a short description of this
program. The description is defined in the Remoting dialogue.
IP address: This column displays the IP address of the computer
running the echo sounder program.
Logged in: This column displays if the you are logged in to this
echo sounder program entry.
User name: This column displays the user name to be used
when logging in to the program. The user name must exist
on the remote application for the log in to succeed. For more
information on adding users refer to the Remoting dialogue.
Access level: This column displays the access level for the user
name.

Buttons

Change user: Click this button to change the user name used
when logging in to the selected entry. Once pressed, the Users
and Passwords dialogue box opens.
Log in: Click this button to log in to the selected entry.
Log out: Click this button to log out from the selected entry.
Select: Click this button to define the selected (highlighted) entry
as the current data source.

Related topics

Remoting on page 139
Log In on page 115
Users and Passwords on page 163
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Delete Layer
The Delete Layer function is accessed from the Echogram and
Numerical short-cut menus.

Purpose

This command is used to delete the active (selected) layer in the
view. The layer is identified with red text in the Numerical view.

Figure 36 Active layer is shown with red text

Use

In the Numerical view, left-click the layer you wish to delete.
Observe that the text in the layer changes to red colour.
Right-click in the Numerical or Echogram views to open the
short-cut menu. Click Delete Layer on the menu.

Related topics

New Layer on page 123
Layer Properties on page 112
Numerical view on page 51
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Depth Output
The Depth Output dialogue box is accessed from the Output
menu.

Purpose

This dialogue box is used to output depth data from the echo
sounder to a dedicated communication port on a specified format.

Use

Click Output→Depth to open the dialogue. In the left column,
select output port, and click the Setup button to set up the
communication parameters. Then, select which telegram to
output, the Talker ID and finally the frequency channel from
which the depth information shall be taken.

Parameters

Port: Select which serial or LAN port to be used for the data
communication.
Setup: If required, you can set up the necessary communication
parameters for the selected port. Note that the changes made for
the applicable port are global.
Telegram: Choose telegram format on the output stream. A list
of permitted types is available.
Talker ID: Select NMEA Talker ID.
Channel: Select from which transceiver channel and frequency
you wish to export the depth data.

Related topics

Port Management on page 130
Serial Port Setup on page 147
LAN Port Setup on page 111
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Echogram
The Echogram dialogue box is accessed from the Echogram
short-cut menu.

Purpose

This dialogue box is used to specify what should be displayed in
the Echogram view, and how sample data shall be converted to
pixel data. The following tabs are used:
• Type
• Lines
• Pixels

Use

Right-click in the Echogram view to open the short-cut menu,
and select Echogram. Make the necessary adjustments.

Related topics

Surface Range on page 151
Bottom Range on page 69
Echogram view on page 48
Annotation on page 65
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Type tab

These parameters are used to specify which types of information
to be displayed in the Echogram view.

Parameters

The dialogue tab provides two parameter fields.

Parameters

These selections define the range reference. All ranges in the
Echogram view can be referenced to either the surface or
the bottom depth detected by the echo sounder. The current
depth range is specified in the Surface Range and Bottom Range
dialogues.

Backscatter

These selections define the type of acoustic backscatter data to be
displayed in the Echogram view.
Pr (No TVG): Power.
Sv (20 log TVG): Volume backscattering strength.
Sp (40 log TVG): Point backscattering strength.
TS (40 log TVG): Target strength. Only signals accepted as single
targets are displayed. These values are beam compensated.
Sp & TS (40 log TVG): Point backscattering strength overlaid
with Target strength data.
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Lines tab

These parameters are used to specify which lines that are to be
displayed in the Echogram view.

Parameters

Horizontal

Bottom: When enabled, the detected bottom depth is shown as
a thin line in the echogram. The line is drawn in the current
foreground colour; black during day and white during night. If
you selectWhite Line, a band in the current background colour is
drawn below the detected bottom depth.
Trawl: When enabled, the headrope and footrope depth are
indicated by two lines in the echogram.
Scale: Equidistant horizontal scale lines are drawn inside the
echogram in the current foreground colour; black during day and
white during night. A maximum of 50 scale lines can be drawn.
No scale lines are drawn when the scale line count is set to zero.

Note

You may wish to include trawl lines in the echograms. If the
distance from the vessel to the trawl is either manually set
different from 0 (zero) in the Trawl dialogue, or the trawl
datagram contains a distance different from 0, you will need to
enable the distance counter in the Navigation dialogue.
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Vertical

Ticks: When enabled, this function places vertical markers on the
echogram. If you select Ping, a short vertical line is drawn in
the upper part of the echogram once every specified number of
pings. Time places a short vertical line is drawn in the upper part
of the echogram once every specified number of seconds, while
Distance inserts a short vertical line is drawn in the upper part of
the echogram once every specified number of nautical miles.
Annotation: Select Text or Line to allow annotations to be
displayed in the Echogram view. If you click Line, the text
annotation will be followed by a vertical line for improved
visibility.
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Pixels tab

These parameters are used to specify how sample data are
converted to pixel data.
Each ping consists a given number of data samples, where the
number of samples is set by the current depth range. This number
of samples does not necessarily match the number of vertical
pixels in the Echogram view. The data samples must therefore
be compressed or expanded to fit the number of available pixels.
In other echo sounders, this function is handled automatically
without allowing the user to control the process.

Parameters

Compression

These options describe the situation when the number of samples
is higher than the number of pixels, and multiple samples are
compressed into one pixel.
Mean : The mean of the samples is used as pixel value.
Peak: The peak value of the samples is used as pixel value.

Expansion

This section describes the situation when the number of samples
is lower than the number of pixels, and the sample values are
expanded to pixel values.
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Interpolation: Pixel values are interpolated between two sample
values.
Copy: A sample value is copied into multiple pixel values.
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EK500 Datagram
The EK500 Datagram dialogue box is accessed from the File
Output and Ethernet Output dialogues.

Purpose

This dialogue is used to specify which EK500 datagrams to
output. Note that changes made in this dialogue will have effects
on both Ethernet and file output of EK500 data.
• Datagram
• Range
• Echogram

Use

Access the dialogue from the File Output or Ethernet Output
dialogues. Make the necessary adjustments.

Related topics

Single Target Detection on page 148
Surface Range on page 151
Bottom Range on page 69
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Datagram tab

Check the boxes for to select which datagrams to output. For
a detailed specification of the datagrams, refer to the Simrad
EK500 Operator manual.

Parameters

Sample Data: Click to include angle, power, sound velocity and
target strength data.
Echo Trace Setup: Click this button to specify parameters for
the Echo Trace datagram. The button opens the Single Target
Detection dialogue. For more information, see Single Target
Detection on page 148.
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Range tab

This tab allows you to specify the range for the Echogram, Echo
Trace and Sample Data datagrams.

Parameters

Surface Range: Click this button to choose the surface range for
the datagrams. The button opens the Surface Range dialogue. For
additional details, see Surface Range on page 151.
Bottom Range: Click this button to choose the bottom range for
the datagrams. The button opens the Bottom Range dialogue. For
additional details, see Bottom Range on page 69.
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Echogram tab

This dialogue box allows you to define the number of surface and
bottom values for the Echogram datagrams.

Parameters

No. of Surface Values: Select the number of echogram samples to
export in the pelagic part of the datagram.
No. of Bottom Values: Select the number of echogram samples to
export in the bottom part of the echogram.
TVG Type: Specify the TVG type for the data in the Echogram
datagram.
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Environment
The Environment dialogue box is accessed from the Install menu.

Purpose

This dialogue box controls the setting of environmental
parameters. These parameters are used for estimating range,
propagation loss, and spreading loss, all of which are essential
concepts in the echo sounder.
The absorption coefficient can be recalculated and displayed for
various frequencies to examine the effect of temperature, salinity,
and sound speed parameters on this parameter.

Use

Click Install→Environment. Make the necessary adjustments.

Parameters

The Trawl dialogue holds three parameter fields.

Conditions

Use these spin boxes to provide manual values for temperature
and salinity. If you operate in fresh water, set salinity to 0 (zero).
Temperature: Use this spin box to select water temperature in °C.
Salinity: Use this spin box to select salinity in ppt.

Sound speed

Calculate: Click this option if you wish the echo sounder
to calculate the sound speed value based on the specified
temperature.
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Manual: Click this option if you wish to enter the sound speed
manually. Use the spin box.

Absorption

Select the frequency in the top spin box, and read the
corresponding absorption value. This input has no effect on the
echo sounder, it is simply a calculator!
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Errors
The Errors dialogue box is accessed by clicking the Errors button
on the Status bar.

The same dialogue is also used with other message types
presented by the ER60. Warnings are indicated with a yellow
button on the Status bar, while errors are indicated with a red
button. Click the button to open the dialogue.

Purpose

This dialogue will list all the current error messages from the
ER60.

Use

Click on the message to read the full text in the text box below the
list. Click Ack to acknowledge the message, or Delete to remove
it from the list. If you wish to delete all messages, click Delete all.

Related topics

Status bar on page 43
Warnings on page 165
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Ethernet Output
The Ethernet Output dialogue box is accessed from the Output
menu.

Purpose

This dialogue box is used to specify the communication settings
for the EK500 Ethernet interface.
Note that additional data can be output to Ethernet using the data
subscription mechanisms in the Data Source dialogue box.
To support programs which use data from the Simrad EK500
echo sounder, the ER60 can output a subset of the EK500 defined
datagrams. This dialogue allows you to enable or disable the
EK500 datagram output to the Ethernet.

Use

Click Output →Ethernet to open the dialogue. Click Output
EK500 to enable output on this format, and click the EK500
Datagram button to define which information that shall be
included. Set up the communication settings as required.

Parameters

EK500 Output

Output EK500: Click this box to enable or disable the EK500
datagram output.

Note

In order to disable EK500 datagrams, you must also open the
EK500 Datagram dialogue and clear all data format check boxes.

EK500 Datagram: Click the button to open the EK500 Datagram
dialogue to set up the individual datagrams.
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Communication parameters

Remote port: Use the spin box to define the UDP port number to
which the data shall be transmitted. Note that parameter request
(PR) is only accepted on port 2000.
Remote IP address: Use the spin boxes to define the IP Address
of the remote computer.
Local IP Address: If you have more than one network cards in
your ER60 Processing Unit, use this box to select which network
card to use for output data.
Communication mode: Choose Broadcast or Point-to-Point.

Related topics

Data Source on page 80
EK500 Datagram on page 90
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Exit
The Exit function is accessed from the Operation menu.

Purpose

Use this option to close the ER60 application.

Use

Click Operation →Exit.
Note that when you exit the ER60, the echo sounder closes down
just like any other standard application. You can restart the ER60
by double-clicking on the desktop icon.
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File Output
The File Output dialogue box is accessed from the Output menu.

Purpose

This dialogue box is used to specify which output you wish to
save to a data file, and in which disk directory the data file(s)
shall be placed. The dialogue provides three tabs:
• Directory
• Raw Data
• Processed Data

Use

Click Output→File Output. Click one of the three tabs, and make
the necessary adjustments.

Related topics

Replay on page 144
EK500 Datagram on page 90
HAC Datagram on page 106
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Directory tab

This tab allows you to define where the data files are stored.

Parameters

Current output directory: This field displays the file path
currently selected to store the files.
Browse: Click this button to select where to store the files.

164692/C 101



Simrad ER60

Raw Data tab

Raw data files can be recorded by the echo sounder and stored
to file. These raw data files can later be replayed by the echo
sounder for further analysis.

For more information on replaying raw data files refer to the
Replay dialogue box. For more information on the data format
for the raw data files refer to the Data formats chapter. Each raw
data file name has the format:

PREFIX
DYYYYMMDD
THHMMSS

Parameters

The Raw Data tab holds three parameter fields.

General

Save Raw Data: Check this box to save raw data to file.
File Name Prefix: Type any name into the text box. The chosen
name will be used as prefix in all the raw data file names.
Range: Use this spin box to define which range to collect echo
sounder data from.

File size

New files will be automatically generated by the echo sounder
program when the specified limit is reached.
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Max. Vessel Distance: Use this spin box to define a limit (in
nautical miles) for the maximum distance to be contained in one
file. A value of 0 means no limit.
Max. File Size: Use this spin box to define a limit for the
maximum amount of bytes to be contained in one raw data file.
A value of 0 means no limit.
Current File Size: When recording raw data is in progress the
current file size is displayed.

Automatic start

Raw data output can be set to start automatically after a
predefined sailing distance.
Start at vessel distance: Select required sailing distance (in
nautical miles) before raw data output is initiated.
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Processed Data tab

Data processed by the echo sounder data can also be stored to file.

To support programs using data from the Simrad EK500 echo
sounder, the ER60 can output EK500 defined datagrams on
Ethernet. These datagrams can also be recorded onto a file.

Parameters

EK500

Save EK500: Check this box to choose to save EK500 datagrams
to file.

Note

In order to disable this function, and to stop the echo sounder
from saving EK500 datagrams to file, you must first clear this
check box, and then restart the ER60 echo sounder application.

EK500 Datagrams: Click this button to open the EK500 Datagram
dialogue box to set up the individual datagrams. For more
information, see EK500 Datagram on page 90.

HAC

Save HAC: Check this box to choose to save HAC datagrams
to file.
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HAC Datagram: Click this button to open the HAC Datagram
dialogue box to set up the individual datagrams. For more
information, see HAC Datagram on page 106.

164692/C 105



Simrad ER60

HAC Datagram
The HAC Datagram dialogue box is accessed from the File
Output dialogue.

HAC is a data exchange format defined by ICES (International
Council for the Exploration of the Sea). It is a standard format for
raw and edited hydroacoustic data. The information is organised
in tuples. A tuple is a labelled group of bytes encapsulating
special type of information in the HAC format. They forms the
basic structure of the format, allows versatility, and makes it
possible to perform upgrades. Tuples belongs to tuple families or
classes that groups the information by themes. Unique numbers,
varying from 0 to 65535, identify each tuple.
For more information, see http://www.ices.dk.

Purpose

Use this dialogue to set up which HAC datagrams to be exported.
The following HAC tuples are currently supported by the Simrad
ER60:
• HAC signature (65535)
• End of file (65534)
• Standard position (20)
• Simrad EK60 echo sounder (210)
• Simrad EK60 channel (2100)
• Ping U-16 (10030)
• Ping U-16-angles (10031)
• Single targets (10090)
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Use

Access the dialogue from the File Output dialogue. Make the
necessary adjustments.

Parameters

Range: Click to open the Surface Range dialogue. The range
specified is the valid range for all ping and single targets HAC
data.
Navigation: Click to enable export of position data.

Sample data

Click to select which sample data types to export: angle, power,
sound velocity or target strength.

Single target data

Single Target: Click to enable export of single target data.
Single Target Detection: Click this button to define the single
target detection properties. The Single Target Detection dialogue
opens.

Related topics

File Output on page 100
Single Target Detection on page 148
Surface Range on page 151
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Hide View
The Hide View function is accessed from all the short-cut menus.

Purpose

This function hides the view from which the command was
chosen.

Use

Right-click in any view to open the short-cut menu, then click
Hide View.
The view can be re-established by selecting Configure Window
from the short-cut menu in another view in the same window, and
check the box for the view which was initially hidden.

Related topics

Configure Window on page 78
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Histogram
The Histogram dialogue box is accessed from the Single Target
Histogram short-cut menu.

Purpose

This dialogue is used to set parameters for the histogram
displayed in the Single Target Histogram view.

Use

Right-click in the Single Target Histogram view to open the
short-cut menu. Click Histogram on the menu, and make the
necessary adjustments.

Parameters

Max. Percentage: Use the spin box to define maximum value for
the percentage axis in the histogram display.
Resolution: Defines the width of each bin in the histogram.

Related topics

Single target histogram view on page 47
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Horizontal Axis
The Horizontal Axis dialogue box is accessed from the Echogram
short-cut menu.

Purpose

This dialogue is used to set the horizontal display span of the
Echogram view.

Use

Right-click in the Echogram view to open the short-cut menu.
Select Horizontal Axis from the menu. Make the necessary
adjustments.

Parameters

Distance: The echogram view displays the specified distance
span.
Time: The echogram view displays the specified time span.
Ping: The echogram view displays the specified ping span.
Check the View size box to specify that the number of horizontal
pixels shall define the number of displayed horizontal pings (One
ping per pixel).
Label: Check the label type used to display the horizontal span.

Related topics

Echogram view on page 48

110 164692/C



References

LAN Port Setup
The LAN Port Setup dialogue box is accessed from the Port
Management dialogue as well as other dialogues handling serial
lines.

Purpose

The purpose of this dialogue box is to set up the parameters
for LAN (Local Area Network) communication with external
sensors.

Use

Set up the parameters for IP address, communication mode,
remote IP address and remote port.

Parameters

Local IP Address: Select local network card if more than one is
available.
Local port: Specify local port.
Remote IP Address: Select remote computer. If the data
communication is set up to receive data only, this parameter is
not required. If you wish to set up an output for broadcast, define
IP address 255.255.255.255. This is the default setting.
Remote port: Specify remote port. If the data communication is
set up to receive data only, this parameter is not required.

Related topics

Port Management on page 130
Navigation on page 118
Motion on page 117
Trawl on page 160
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Layer Properties
The Layer Properties dialogue box is accessed from the Echogram
and Numerical short-cut menus.

Purpose

This dialogue is used to edit the properties for the active layer.
Layers are used to calculate various values for a specific range
in the water column. The calculated values can be displayed
in the Numerical view. All single targets detections which are
displayed in the Single Target Position view and the Single Target
Histogram view are detected within a layer.

Use

In the Numerical or Echogram view, right-click to open the
short-cut menu. Click Layer properties on the menu to open the
dialogue, and make the required adjustments.

Parameters

Limits

Start Relative Surface: This parameter controls the depth at
the upper boundary of the layer, relative to the surface depth
depending on the selected layer type.
Start Relative Bottom: This parameter controls the depth at the
upper boundary of the layer, relative the detected bottom depth
depending on the selected layer type.
Range: This parameter controls the vertical depth range for the
layer. Please note that positive is always downwards. This means
that a start range relative bottom of for example -10 m means 10
m above bottom.
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Type

Surface: The range settings for the layer are referenced to the
surface. The layer is downwards limited by the detected bottom
depth if this value is shallower than the specified lower range
limit for the layer. Pings without bottom detections are ignored
in the calculations.
Pelagic: The range settings for the layer are referenced to the
surface. The layer is not downwards limited by the detected
bottom depth.
Bottom: The range settings for the layer are referenced to the
bottom. The layer is downwards limited by the detected bottom
depth.

Integration

Targets Integration: Check this box to calculate integration values
based on single target detections. Compared with the normal
integration (sA) this value can be used to get an idea of how
much of the biomass has been detected as single targets.
Margin: This is the margin to the surface and the bottom used
when calculating integration values for Surface and Bottom types.
Sv threshold: This is the lower threshold used when calculating
integration values for the layer.

Related topics

New Layer on page 123
Delete Layer on page 82
Echogram view on page 48
Numerical view on page 51
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Load Settings
The Load Settings dialogue box is accessed from the Options
menu.

Purpose

This dialogue is used to load previously saved settings.
Program settings can be saved to files. This dialogue displays a
list of previously saved setting files. These files are located in the
directory displayed in the File Path box. Note that installation
settings (e.g. Transceiver and sensor installation settings) are
not saved in the settings files.

Use

Click Options →Load Settings. Select a setting file by clicking
once on the file name, then click OK.

Parameters

The dialogue box holds two text fields and one button.
File name: This box lists the current setting file by their file
names.
File path: This box displays the path (location on the hard disk)
of the currently selected setting file.
Delete File: Select a setting file, then click this button to delete
the file from the hard disk.

Related topics

Save Settings on page 146
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Log In
The Log In dialogue box is accessed from the Operation menu.
The dialogue will also appear automatically when you switch on
the echo sounder.

Purpose

This dialogue is used to log in to the echo sounder program. The
user name must exist on the application for the log in to succeed.

Use

Enter user name and password. Click to enable Auto login if you
want to log in automatically when the sounder software is started,
and thus bypass this dialogue.

Parameters

The following parameters are contained by the Log In dialogue.
User name: This is the name used to identify the person that
wishes to use the echo sounder application.
Password: This is a code string used to verify that the person who
wishes to use the echo sounder is the correct user.
Auto login: When this check box is enabled, the log in process is
disabled. Any person will then be able to use the echo sounder
application.

Related topics

Log Out on page 116
Users and Passwords on page 163
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Log Out
The Log Out function is accessed from the Operation menu.

Purpose

This function allows you to log out.

Use

Click Operation →Log Out.

Related topics

Log In on page 115
Users and Passwords on page 163
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Motion
The Motion dialogue box is accessed from the Install menu.

Purpose

This dialogue controls the installation of external motion sensors.
The heave information is used in the bottom depth estimation,
and also for display and output of echogram data. Display
of roll and pitch information can be useful when replaying
previously recorded data files. Note that heave information may
be monitored in the status bar.

Use

Click Install→Motion, and make the necessary adjustments.

Parameters

Port: Select the input port that is used to receive the information.
The available ports will reflect the source choice.
Setup: Set up the selected port. This will open a dedicated
dialogue to set up the relevant communication parameters.
Protocol: Select data protocol.

Related topics

LAN Port Setup on page 111
Serial Port Setup on page 147
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Navigation
The Navigation dialogue box is accessed from the Install menu.

Purpose

This dialogue box controls the installation of position, speed,
and travelled distance information from external sensors. The
dialogue provides three tabs:
• Distance
• Position
• Speed

Use

Click Install→Navigation. Click one of the three tabs, and make
the necessary adjustments.

Related topics

LAN Port Setup on page 111
Serial Port Setup on page 147

118 164692/C



References

Position tab

The echo sounder receives vessel position information using
standard NMEA datagrams.

Parameters

Port: Select the input port that is used to receive the position
information.
Setup: Set up the selected port. This will open a dedicated
dialogue to set up the relevant communication parameters.
NMEA sentence: Select which datagram to use.
Talker ID: Specify the NMEA talker identity (the first two
characters in the NMEA sentence). Use None to accept all talker
identifiers.
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Speed tab

This tab controls the vessel speed input.

Parameters

Port: Select the input port that is used to receive the speed
information.
Setup: Set up the selected port. This will open a dedicated
dialogue to set up the relevant communication parameters.
NMEA sentence: Select which datagram to use.
Manual speed: If speed information is unavailable, click the box
and set manual speed with the spin box.
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Distance tab

The echo sounder receives vessel distance information either
internally derived from speed information, via NMEA datagrams,
or from 1/200 nmi contact pulses.

Note

You may wish to include trawl lines in the echograms. If the
distance from the vessel to the trawl is either manually set
different from 0 (zero) in the Trawl dialogue, or the trawl
datagram contains a distance different from 0, you will need to
enable this distance counter.

Parameters

Source: Select the source for the distance information; datagram,
speed or hardware pulse.
Port: Select the input port that is used to receive the information.
The available ports will reflect the source choice.
Setup: Set up the selected port. This will open a dedicated
dialogue to set up the relevant communication parameters.
NMEA sentence: Select which datagram to use.
Distance: The current vessel distance can be set manually.
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New Channel
The New Channel function is accessed from theWindow menu.

Purpose

This command is used to display a new channel window. This
can either be a new frequency channel, or a new view of an
existing frequency channel.

Use

Click Operation →New Channel. Select channel from the
sub-menu presenting the different transceiver/transducer
channels installed on the echo sounder.
Displayed channel windows are listed at the bottom of the
Window menu. To view the channel windows, use the Cascade or
Tile commands on theWindow menu. To close a channel, press
the “X” at the top right corner of the channel window. To close
all channels, select Close All on theWindow menu.

Remark

Sampling, data storage or data output from a frequency channel is
not influenced by opening or closing channel windows. However,
the maximum available ping rate may be affected by the range
settings in a channel window.

Related topics

Cascade on page 72
Close All on page 73
Tile on page 153
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New Layer
The New Layer function is accessed from the Echogram and
Numerical short-cut menus.

Purpose

This dialogue is used to insert a new vertical layer.

Use

All parameters are identical to the Layer Properties dialogue. See
Layer Properties on page 112.

Related topics

Layer Properties on page 112
Delete Layer on page 82
Numerical view on page 51
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Normal Operation
The Normal Operation dialogue box is accessed from the
Operation menu.

Purpose

This dialogue is used to define the basic operational parameters
for the installed transceiver channels. Note however, that

Note

All transceivers must be installed (Install →Transceiver) before
you can use this dialogue!

Parameters

The dialogue box is built like a table, where each transceiver
channel is listed in a row.
Channel: The is column lists the transceivers that have been
installed using the Transceiver command on the Install menu.
Mode: This is the operational status for the channel.
• Active: The transmitter and receiver are active (normal
operation).

• Passive: The transmitter is passive while the receiver is active.
This mode of operation is useful for test purposes, and when
you wish to measure the ambient background noise in the sea.

• Test: An internal test signal (-70 dBW) is generated internally
by the transceiver.

Pulse duration / Sample interval / Bandwidth: These parameters
are interdependent, and can not be changed individually.
However, for each transceiver channel you may choose from a
set of parameter groups.
Transmit Power: This parameter controls the transmitter’s output
power. Output power is limited either to the maximum rating
of the transducer, or the maximum rating of the transmitter,
whichever is the smallest.
Depth: This parameter defines the installation depth for each
transducer.
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Pulse duration

This parameter controls the duration of the transmit pulse. The
table below shows the pulse duration (given in μS) available for
the different operational frequencies.

Table 4 Pulse duration

kHz 64 128 256 512 1024 2048 4096 8192 16384

12 — — — — OK OK OK OK OK

18 — — — OK OK OK OK OK —

38 — — OK OK OK OK OK — —

70 — OK OK OK OK OK — — —

120 OK OK OK OK OK — — — —

200 OK OK OK OK OK — — — —

X-axis is pulse duration in μS, Y-axis is frequency in kHz. “OK” means that the pulse duration is available
for the given frequency.

Multiplexer operation

When the ER60 Scientific echo sounder is operated with a
multiplexer, both transceiver channels are shown in the Normal
Operation dialogue.

In this mode, you are permitted to change transducer depth,
pulse duration, sample interval and bandwidth for the second
transducer, but you can not changed the mode and power output.
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Numerical View
The Numerical View dialogue box is accessed from the Numerical
short-cut menu.

Purpose

This dialogue is used to select which information is displayed
in the Numerical view.

Use

Right-click in the Numerical view to open the short-cut menu.
Click Numerical on the menu. Check the boxes in front of the
information you wish to see. For additional information about
the alternatives, see the Numerical view description.

Related topics

Numerical view on page 51
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Open All
The Open All function is accessed from theWindow menu.

Purpose

Use this command to open all currently activated windows.

Close all windows

To close windows, click Close All on theWindow menu.

Related topics

New Channel on page 122
Cascade on page 72
Tile on page 153
Close All on page 73
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Ping Control
The Ping Control dialogue box is accessed from the Operation
menu.

Purpose

This dialogue is used to control the echo sounder pinging during
both normal and replay operations. All settings in this dialogue
take immediate action. Note that the majority of operations
carried out in this dialogue box can also me made on the toolbar.

Use

In Maximum mode, click the Start button to start pinging. This
operation will toggle the button text to Stop, which you can click
to stop pinging.
In Interval mode, set the interval time in the spin box, and use
the Start / Stop button to initiate the pinging.
In Single step mode, click the Single step button to transmit a
single ping.

Parameters

The dialogue box holds three parameter fields.

Operation

Start / Stop: Click this button to start or stop the pinging in
Maximum and Interval modes.
Single step: Click this button to transmit one single ping in Single
step mode.

Ping rate

The Ping rate can be set to either Maximum, Single step, or
Interval.
Maximum: Select this mode to set the echo sounder to transmit
pings as often as possible. In normal operation the ping rate will
typically be limited by the time it takes for the sound to travel to
the range requested by the user and back. Use the Max ping rate
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parameter displayed in the Numerical view for display of this
range. For short data collection ranges in normal operation, the
ping rate will be limited by the transceiver’s need to recharge
before a new ping can be transmitted. During replay operation
the maximum ping rate will mainly be limited by the computer’s
processing capacity.
Single step: Select this mode to transmit only a single ping each
time the Single step button is clicked.
Interval: Select this mode to set the echo sounder to transmit a
ping once every set time. If the system is not ready to transmit
a ping due to the limitations described for maximum ping rate,
this ping will not be transmitted. Use the spin box to set the time
interval in seconds.

Triggering

The echo sounder can be set up to either supply trigger to a
remote system, or be triggered by external instruments. Note that
triggering is only available in the Normal ping mode.
Ingoing: Check this box to be triggered by an external instrument.
The ping transmission will be delayed until a pulse is detected at
the source. Select the source using the list box.
Outgoing: Check this box to generate an output signal at the
selected source each time a ping is transmitted. Use the list box
to select the output where the trigger signal will appear.
The external triggering system is explained in more detail in the
Instruction manual. Refer to the Cable layout chapter.
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Port Management
The Port Management dialogue box is accessed from the Install
menu.

Purpose

The Port Management dialogue allows you to control the
properties of each of the available communication channels
on the computer. The ER60 software automatically scans the
computer to locate and identify ethernet and serial line interfaces.
USB interfaces are only recognized if they are defined to
communicate serial data. Once the software has established a list
of valid interfaces, you can set up and control the parameters.
The dialogue provides two lists, one for serial ports and one for
LAN ports.

Use

Click Install →Users and Passwords. To modify the user
properties, click the name on the list, and then Properties.
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Parameters

Serial ports

Protocol: Each serial line can communicate with more than one
sensor simultaneously provided that each sensor use the same
protocol.
Sensors: This column is used to identify the external sensor
currently connected to the serial line.
Add: If you have added additional serial lines to the computer
(for example by installing an extra interface circuit board), you
can click Add to identify the new ports. If you have previously
released an unused serial port, but wish to bring it back to ER60
use, you must also press Add to include it.
Remove: Once the ER60 has identified and listed all the available
serial lines on the computer, these can not be used by any other
software applications on the same computer. However, if the
ER60 does not need a specific serial line, it can be released for
other use when you select it and press the Remove button.
Setup: Select a serial line and press the Setup button to define
the communication parameters.
Monitor: Select a serial line and press theMonitor button to open
the Port Monitor dialogue. This feature allows you to monitor the
traffic on the serial line.

LAN ports

Local IP: This is the IP number of the network card in your
computer that you wish to use.
Local port: This is local port you wish to use.
Remote IP: This is the IP number of a remote computer.
For point-to-point communication, you must define this IP
address. If you wish to broadcast information, enter IP number
255.255.255.255. For inputs, you do not need to set up this
parameter.
Remote port: Set up the remote port only if applicable for
point-to-point data export.
Protocol: Each ethernet line can communicate with more than
one sensor simultaneously provided that each sensor use the
same protocol.
Sensors: This column is used to identify the external sensor
currently connected to the serial line.
Add: If you wish to assign a new port to the existing network
card, or add a new network card, press Add to identify the new
port(s).
Remove: Use this feature to remove ports you do not need.
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Setup: Select a LAN port and press the Setup button to define
the communication parameters.
Monitor: Select a LAN port and press theMonitor button to open
the Port Monitor dialogue. This feature allows you to monitor the
traffic on the LAN port.

Related topics

Serial Port Setup on page 147
LAN Port Setup on page 111
Port Monitor on page 133
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Port Monitor
The Port Monitor dialogue box is accessed from the Port
Management dialogue box.

Purpose

The Port Monitor dialogue allows you to check and verify that the
data transmissions in and out from the ER60 are fully functional.

Use

Click Install →Port Management to open the Port Management
dialogue. Click once on a serial line or LAN port to select it,
and then on the Monitor button.
During normal operation, the traffic shown on the serial lines and
LAN ports are is limited to the NMEA telegrams and certain
proprietary telegrams, as well as the serial port synchronisation
signals. You will not be able to monitor the traffic between the
computer and the transceiver.
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During replay, the NMEA telegrams and certain proprietary
telegrams stored in the raw data file are shown on the LAN ports.

Parameters

Tx data

Text window: The text window is used to display the data
communication transmitted from the ER60.
Auto update: Check this box to allow the information in the text
window to be automatically updated.
Hex display: Check this box to have the data communication
presented in hex format.
Delete: Click this button to clear the text window.

Rx data

Text window: The text window is used to display the data
communication received by the ER60.
Auto update: Check this box to allow the information in the text
window to be automatically updated.
Hex display: Check this box to have the data communication
presented in hex format.
Delete: Click this button to clear the text window.

Other parameters

Current port: You can use this spin box to select an other serial
line or LAN port. This allows you to choose an other port without
returning to the Port Management dialogue.
Always on top: Check this box if you with the dialogue to stay on
top of the echo sounder windows. You are not recommended to
use this feature during normal operations.

Related topics

Serial Port Setup on page 147
LAN Port Setup on page 111
Port Management on page 130
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Print
The Print Preview dialogue box is accessed from all the short-cut
menus.

Purpose

This dialogue box allows you to print the current view.

Use

Right-click in any view to open the Depth short-cut menu, then
click Print. Select printer, and adjust the printer properties if
necessary.

Parameters

This is a standard operating system dialogue box. The appearance
may differ between the operating systems, and the text will be in
the operating system’s language.
Name: Printer name. Select the printer you wish to use.
Properties: If necessary, click this button to modify the printer
properties.

Related topics

Print Preview on page 136
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Print Preview
The Print Preview dialogue box is accessed from all the short-cut
menus.

Purpose

This dialogue allows you check the printout before you send the
job to the printer. Note that this is a standard operating system
dialogue. The appearance may differ between the operating
systems, and the text will be in the operating system’s language.

Use

Right-click in any view to open the Depth short-cut menu, then
click Print Preview.

Tool bar symbols

This is a standard operating system dialogue box. The appearance
may differ between the operating systems, and the text will be in
the operating system’s language.

Sends the job to the default printer. Note that the Print
dialogue does not appear, so you if you wish to use a printer other
than your default, you need to change this before you open the
Print Preview dialogue.

Zoom tool
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Allows you to print a multiple page document
onto one paper page. This function is not applicable for the
ER60, as the built-in printing functionality only will provide a
single page output.

Will close the dialogue.

Allows you to print a selected page from a multiple
page document. This function is not applicable for the ER60.

Related topics

Print on page 135
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Range
The Range dialogue boxes are accessed from the Echogram
short-cut menu.
The dialogue title and the range settings will be surface related
if the dialogue is opened while the echogram displays a surface
referenced echogram.
The dialogue title and the range settings will be bottom related
if the dialogue is opened while the echogram displays a bottom
referenced echogram.

Related topics

Bottom Range on page 69
Surface Range on page 151
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Remoting
The Remoting dialogue box is accessed from the Install menu.

Purpose

This dialogue controls setting of parameters related to remote
operation of the echo sounder. With these parameters, you can
operate the echo sounder from an other computer connected to
the network. The dialogue provides two tabs:
• Server
• Client

Use

Click Install→Remoting. Click one of the two tabs, and make the
necessary adjustments.

Related topics

Data Source on page 80
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Server tab

The echo sounder program can function as a data server for other
programs running on other computers connected to the LAN. In
this case data are transferred as UDP packets from/to the server
through an Ethernet card with a specific IP address. The server
page is only used if you want to use the echo sounder program as
a server for other client programs.

Parameters

The Server tab contains two parameter fields.

Browse request handling

If you have two network cards in your computer we strongly
suggest that you:
• use the first network card for communication with the echo
sounder transceiver

• use the second network card for data transfer between the
server (the ER60 computer that controls the transceiver) and
clients (peripheral computers in the network)

The two network cards are then connected to two different
networks.
Specify network card for server functionality by selecting the
appropriate IP address from the list. The initial connection
between a server and a client is created through on a specific UDP
port number on the server. When the connection is established
data communication is transferred to a new UDP port number
which is automatically assigned by the server. The default local
port number for the initial connection can be changed if you want
to use a specific local port number, normally this is not necessary.
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Local IP address: Choose the IP address of the network card in
your computer that shall communicate with other clients.
Local port: Define the port on the computer. Unless special
requirements dictate otherwise, use 37655. This is the default
value.

Application information

When the server application (the ER60 Scientific echo sounder)
exposes itself it exposes various application information. The
description and ID exposed can be set here.
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Client tab

The echo sounder program can function as a client receiving data
from an echo sounder program running on another processing
unit connected to the LAN. In this case data are transferred as
UDP packets from/to the client through an Ethernet card with a
specific IP address.

The client page is only used if you want to use the echo sounder
program as a client receiving data from another echo sounder
program. If you have more than one network card you can
select which one to use for client operations from the list of IP
addresses. The remote port number is the port number on the
server (the ER60 computer that controls the transceiver) which
is used to establish the initial connection. This number must
be equal to the local port number found on the server page in
the Remoting dialogue on the remote server which you wish to
connect to. Normally the client broadcasts a message to obtain
information on echo sounder programs running on the local area
network. A list of these programs is displayed when the Data
Source dialogue is opened. In some network configurations
broadcasting is not a practical solution, and in these cases
the communication mode can be changed from broadcast to
point-to-point and a specific remote IP address for the server
which you want to connect to can be set.

Parameters

The Client tab holds one parameter field.

Server browsing

Local IP address: Enter the IP address of the network card in your
computer that shall communicate with the remote server.
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Remote IP address: Enter the IP address of the remote server.
Remote port: Enter the port number used on the remote server.
Communication mode: Choose Broadcast or Point-to-point
depending on the data distribution requirements.
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Replay
The Replay dialogue box is accessed from the Operation menu.

Purpose

In order to investigate stored data, the echo sounder may be set
up in Replay mode. This dialogue is used to select one or more
raw data files for replay.

Use

To make switching between different replay files easier you can
add multiple files to the displayed file list using the Add button.
Files are removed from the list using the Remove button. For
more detailed usage, refer to the Operational procedures.

Parameters

The Replay dialogue box contains a list of current replay files,
and two buttons.

Files

The list holds the name and path name for the file(s) you have
selected for playback.
Arrows: The two arrow buttons on the right side of the playback
list allows you to modify the order of the files. Click once on a
single file, and then on an arrow button to move the file up or
down.
Add: Click this button to add additional files to the playback
list. A standard file selection dialogue allows you to browse and
select file(s).
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Remove: Click on a file name in the playback list, and then click
this button to remove the file from the list. This button will not
delete the file from the hard disk.

Options

Loop: Click to enable continuous playback of the file(s) in the
playback list.
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Save Settings
The Save Settings dialogue box is accessed from the Options
menu.

Purpose

This dialogue is used to save the current application settings.

Note

Installation settings (e.g. Transceiver and sensor installation
settings) are not saved in the settings files.

Use

Click Options→Save Settings. Type a name for the file to contain
the current settings, then click OK.

Parameters

File name: This field allows you to enter a file name. The name
is used to identify the settings.

Related topics

Load Settings on page 114
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Serial Port Setup
The Serial Port Setup dialogue box is accessed from the Port
Management dialogue as well as other dialogues handling serial
lines.

Purpose

This dialogue is used to set up the serial port for communication
with external sensors.

Use

Set up the parameters for baud rate, number of data bits and
parity to suit the applicable serial line communication.

Parameters

COM port: This box displays the name of the communication
port your are currently editing.
Baud rate: Select to match the communication parameters of
the remote device.
Data bits: Select to match the communication parameters of the
remote device.
Parity: Select to match the communication parameters of the
remote device.

Related topics

Port Management on page 130
Navigation on page 118
Motion on page 117
Trawl on page 160
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Single Target Detection
The Single Target Detection dialogue box is accessed from the
short-cut menus in the Single Target Position and the Single
Target Histogram views. It is accessed directly if you press the
middle mouse button while the cursor is positioned inside the
same views.

Purpose

This dialogue is used to set the operational parameters for
detecting single targets within the active layer.

Use

Access the dialogue from the relevant short-cut menu. Make the
necessary adjustments.

Parameters

Min. Threshold (dB): The target strength for a single target must
exceed this threshold to be accepted.
Min. Echo Length: For a single target detection to occur
the normalized echo length (echo length between the 6 dB
points relative to the peak value divided by the duration of the
transmitted pulse) must exceed this parameter.
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Max. Echo Length: A single target detection requires the
normalized echo length to be less than the maximum echo length
setting.
Max. Phase Deviation: Average electrical phase jitter between
samples inside an echo from a single target must not exceed
the maximum phase deviation setting where maximum phase
deviation is set in units of phase steps (128 phase steps = 180
electrical degrees). Recommended setting is 2 to 3 for normal
conditions. For weak echoes in noisy conditions you should
allow for more jitter (4 to 10).
Max. Gain Compensation: The correction value returned from
the transducer gain model must not exceed the maximum gain
compensation setting. (This is the one-way maximum gain
compensation. The two-way maximum compensation will be 12
dB). All single targets outside the angle corresponding to the
chosen gain compensation are skipped. Thus you can reduce
the sample volume (beam angle) by choosing a lower value for
maximum gain compensation.
Min. Echo Spacing: The is the minimum spacing between two
single echoes required for acceptance.

Calibration

Click the Calibration button to start the dedicated calibration
program with single target detections for this layer.
Note that you must click the Apply button before you start the
calibration program if you have made changes to the single target
detection parameters. This is to ensure that the parameters have
been applied for the layer.

Related topics

Single target histogram view on page 47
Single target position view on page 46
Calibration on page 19
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Status bar
The Status bar function is accessed from the View menu.

Purpose

This is simply an “on/off” switch to show or hide the status bar.
When enabled, the status bar will appear at the bottom of the
echo sounder window.

Use

Click View→Status bar to enable the status bar.
To remove the status bar, repeat the sequence.

Related topics

Status bar on page 43
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Surface Range
The Surface Range dialogue box is accessed from the Echogram
short-cut menu.

Purpose

This dialogue is used to specify the vertical depth range for the
Echogram view.

Use

Right-click in the Echogram view to open the short-cut menu.
Select Range from the menu. Make the necessary adjustments.

Surface or Bottom?

The dialogue title and the range settings will be surface related
if the dialogue is opened while the echogram displays a surface
referenced echogram.
The dialogue title and the range settings will be bottom related
if the dialogue is opened while the echogram displays a bottom
referenced echogram.

Parameters

Bottom: This parameter controls the depth at the upper boundary
of the echogram, relative the transducer face / detected bottom
depth.
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Range: This parameter controls the vertical depth range across
the echogram view. Note that positive is always downwards.
This means that a start range relative bottom of -10 m means 10
m above bottom!
Apply to all: Check this box to apply the new range setting to all
current surface and bottom echograms.

Related topics

Bottom Range on page 69
Echogram view on page 48
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Tile
The Tile function is accessed from theWindow menu.

Purpose

This command is used to display a new channel window. This
can either be a new frequency channel, or a new view of an
existing frequency channel.

Use

This function is identical to the common function available in the
operating system. The active windows are presented tiled; that is
reduced in size and automatically fitted next to each other.

Related topics

Cascade on page 72
Close All on page 73
New Channel on page 122
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Toolbars
The Toolbars function is accessed from the View menu.

Purpose

This is simply an “on/off” switch to show or hide the toolbars.
You can choose to open the Normal Operation or the Easy
Operation toolbars, or both. When enabled, the toolbars will
appear directly below or next to the main menu.

Use

Click View→Toolbars→Normal Operation to enable the Normal
Operation toolbar.
Click View →Toolbars →Easy Operation to enable the Easy
Operation toolbar.
To remove a toolbar, repeat the sequence.

Related topics

Toolbar on page 42
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Tooltip
The Tooltip dialogue box is accessed from the Options menu.

Purpose

This dialogue is used to select which information you wish to
have displayed as “tool tips” (information displayed next to the
cursor) in the different views.

Use

Click Options→Tooltip, and make the necessary changes. Each
view has its own set of parameters which can be switched on
or off.

Related topics

Colour scale view on page 50
Depth view on page 45
Echogram view on page 48
Single target histogram view on page 47
Single target position view on page 46
Scope view on page 49
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Transceiver Installation
The Transceiver Installation dialogue box is accessed from the
Install menu.

Purpose

This dialogue controls installation and disconnection of
transceivers. Every time this dialogue appears on the display the
echo sounder software automatically performs a search on the
Ethernet network for transceivers.

Use

Click Install →Transceiver. Each transceiver is installed by
selecting the correct transducer type for each frequency channel.
Transceivers are disconnected by selecting transducer type None.

Frequency channels

Each transceiver contains one or more frequency channels. Split
beam transceivers contain only one frequency channel each.
The Frequency Channel Selection list displays a list of frequency
channels which either are or have been installed on the echo
sounder.
• Entries shown in black are detected frequency channels which
are not installed, but available for installation.

• Entries shown in green are detected frequency channels,
which are both detected and installed.

• Entries shown in blue are detected frequency channels which
are installed by another echo sounder program, and thus not
available for this application.
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• Entries shown in red are frequency channels which have
previously been installed, but are no longer available.

A frequency channel can be selected by left clicking on the entry
in the list.

Parameters

The Transceiver Installation dialogue holds a list of detected
transceivers as well as three parameter fields.

Frequency Channel Selection

The dialogue displays information about the chosen transceiver.
Information about frequency, transceiver name, number of
channels and transducer type connected is listed on each line.

Transceiver information

Name: The currently selected frequency channel.
GPT SW Version: The current software version in the General
Purpose Transceiver (GPT).
Console IP Address: The IP address of the console running the
echo sounder software.
Network IP Address: Describes which numbers must be identical
between the console IP address and the transceiver IP address for
the transceiver to be identified by the console. Thus, the address
157.237.xxx.xxx describes that all transceiver IP addresses must
start with 157.237.
GPT IP Address: The IP address of the General Purpose
Transceiver (GPT).

Transducer Selection

Selection: This spin box allows you to select a transducer for
the chosen frequency channel.
Transducer parameters: Transducer parameters are normally
automatically updated through the calibration procedure, and do
not need to be changed manually. You can however manually
modify transducer parameters using the Transducer Parameters
dialogue. Click this button to access the dialogue.

Multiplexer Installation

A dedicated multiplexer unit may be connected to the echo
sounder. This allows two transducers to be connected to the
transceiver. Two different modes are available:
• None: Basic mode for normal operation with one single
transducer

• Mux-2: Multiplexer mode with two transducers
Multiplexer Installation: Use the drop-down selector to choose
mode.
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When you enable multiplexer operation, the information about
the General Purpose Transceiver (GPT) is changed to the trlist.ini
file. In order to use this information, the echo sounder application
must be restarted.

Transceiver browsing

These settings allow configuration of network properties when
the system automatically searches for connected transceivers.
Local IP Address: If the computer running the echo sounder
program contains multiple network cards the network card which
is connected to the transceivers can be selected from this list.
Remote IP Address: Normally the search for transceivers should
be broadcasted, and in this case the Remote IP Address field must
be set to 255.255.255.255 and the communication mode must
be set to Broadcast. Changing the Remote IP Address while
selecting communication mode Point-to-point can be used in
special network configurations where this is required.
Communication mode: Select mode from the list; Point-to-point
or Broadcast.
Browse: Click this button to generate a new Frequency Channel
Selection list of transceivers.

Related topics

Transducer Parameters on page 159
Transceiver installation on page 15
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Transducer Parameters
The Transducer Parameters dialogue box is accessed from the
button in the Transceiver Installation dialogue.

Purpose

This dialogue allows you to manually modify key transducer
parameters.

Note

This functionality is for advanced users only!

Changing the transducer name creates a new transducer
definition in the trlist.ini file.

After creating a new transducer, you must disconnect the channel
with the transducer, and the reconnect it. Refer to the operational
procedures.

Related topics

How to disconnect a channel on page 15
Transceiver Installation on page 156
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Trawl
The Trawl dialogue box is accessed from the Install menu.

Purpose

This dialogue controls the installation of trawl sensors. Trawl
information is used for display of upper and lower trawl line in
the echogram. All received speed data are stored to file when
recording of raw data to file is enabled.

Use

Click Install→Trawl. Select input source from the list, and set up
the communication interface.
Note

You may wish to include trawl lines in the echograms. If the
distance from the vessel to the trawl is either manually set
different from 0 (zero) in the Trawl dialogue, or the trawl
datagram contains a distance different from 0, you will need to
enable the distance counter on the Distance tab on the Navigation
dialogue.

Parameters

The Trawl dialogue holds two parameter fields.

Trawl sensor setup

Port: Select one of the serial ports or LAN. If no trawl system is
connected, select None.
Setup: Click this button to open the applicable setup dialogue to
define the communication parameters.
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System: Select ITI, PI30 or Ifremer trawl monitoring systems.
Other third party systems are not supported.

Manual parameters

If trawl opening and/or distance to trawl information is not
automatically available from a trawl system, the parameters can
be set manually.
Trawl opening: Enter the current trawl opening (in meters).
Distance to trawl: Enter the current distance between the echo
sounder transducer and the trawl opening (in meters).

Related topics

Distance tab on page 121
Transducer Parameters on page 159
Transceiver installation on page 15
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User Properties
The User Properties dialogue box is accessed from the Users and
Passwords dialogue.

Purpose

This dialogue is used to change the description, password and
access level for an existing user. If you wish to change the name
as well, you need to delete the user using the Remove button in
the Users and Passwords dialogue, and then click Add to establish
a new user.

Use

Click Install →Users and Passwords. To modify the user
properties, click the name on the list, and then Properties.

Related topics

Users and Passwords on page 163
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Users and Passwords
The Users and Passwords dialogue box is accessed from the
Install menu.

Purpose

This dialogue is used to add and remove users, and to set and edit
user properties and passwords.

Use

Click Install→Users and Passwords. Click Add to add new users.
To delete user, click the name on the list, and then Remove. To
change a password, click the name on the list, and then Properties.

About users

To prevent unintentional operation of the echo sounder the “user”
concept is introduced. Each user is assigned an access level
which can be either:
• Administrator: All rights
• Operator: Limited from performing installation operations
• Observer: Limited from changing settings which will affect
raw data recordings

Four users are built-in accounts. These can not be deleted.
• Administrator: User with Administrator rights
• Operator: User with Operator rights
• Observer: User with Observer rights
• Simrad: User with Operator rights
By default the built-in accounts have empty passwords, but
this can be changed by a user with Administrator rights. When
the echo sounder program is installed for the first time, the
Administrator user will log in automatically during start up.
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Parameters

List of users

The list of current users hold their names, descriptions and access
levels. To select a user, click once on the name in the list.

Buttons

Three buttons are provided to maintain the user list.
Add: Click to add a new user. The Add User Account dialogue
appears to accept user name, description, access level and
password.
Remove: Click to delete the currently select user.
Properties: Click to modify the properties of the currently select
user. The User Properties dialogue appears. It allows you to
change the description, access level and password.

Related topics

Add User Account on page 64
User Properties on page 162
Log In on page 115
Log Out on page 116
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Warnings
TheWarnings dialogue box is accessed by clicking theWarnings
button on the Status bar.
The same dialogue is also used with other message types
presented by the ER60. Warnings are indicated with a yellow
button on the Status bar, while errors are indicated with a red
button. Click the button to open the dialogue.

Purpose

This dialogue will list all the current warning messages from
the ER60.

Use

Click on the message to read the full text in the text box below the
list. Click Ack to acknowledge the message, or Delete to remove
it from the list. If you wish to delete all messages, click Delete all.

Related topics

Status bar on page 43
Errors on page 96

164692/C 165



Simrad ER60

DATA FORMATS
This chapter describes how the echo sounder handles data
formats and interfaces.
The information contained in this chapter is provided for
programmers and technical personnel designing third party
software to communicate with the Simrad ER60 Scientific echo
sounder.

Topics

Numeric type definition on page 167
Raw data on page 168
Data subscriptions and remote control on page 174
Data subscription types on page 191
Parameter descriptions on page 202
NMEA telegram specifications on page 205
Proprietary telegram specifications on page 209
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Numeric type definition
In order to describe the data type formats, common ”C” structures
are used to represent individual data blocks.

Table 5 The size of the various “C” types

char 8-bit integer

WORD 16-bit unsigned integer

short 16-bit integer

Int 32-bit integer

long 32-bit integer

float 32-bit floating point (IEEE 754)

double 64-bit floating point (IEEE 754)

DWORDLONG 64-bit integer
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Raw data
The *.raw file may contain one or more of the following datagram
types:
• Configuration
• NMEA
• Annotation
• Sample
Every *.raw file begins with a configuration telegram. A second
configuration datagram, within the file, is illegal. The data
content of the configuration datagram of an already existing file
cannot be altered from the echo sounder. NMEA, annotation and
sample datagrams constitute the remaining file content. These
datagrams are written to the *.raw file in the order that they are
generated by the sounder.
Note that the information following the “//” sign are comments
to that line.

Topics

Data encapsulation on page 169
Configuration datagram on page 170
NMEA datagrams on page 171
Annotation datagrams on page 172
Sample datagram on page 173
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Data encapsulation
A standard encapsulation scheme is used for all data files. Each
datagram is preceded by a 4 byte length tag stating the datagram
length in bytes. An identical length tag is appended at the end of
the datagram.
long Length;
struct DatagramHeader

{
long DatagramType;
struct {

long LowDateTime;
long HighDateTime;

} DateTime;
};

- -
< datagram content
- -
long Length;
};

All datagrams use the same header. The datagram type field
identifies the type of datagram. ASCII quadruples are used to
ease human interpretation and long term maintenance; three
characters identify the datagram type and one character identifies
the version of the datagram.
The DateTime structure contains a 64-bit integer value stating
the number of 100 nanosecond intervals since January 1, 1601.
This is the internal ”filetime” used by the Windows NT operating
system. The data part of the datagram contains any number of
bytes, and its content is highly datagram dependent.
Common computers fall into two categories:
• Intel based computers write a multibyte number to file starting
with the LSB (Least Significant Byte).

• HP, Sun and Motorola do the opposite. They write the MSB
(Most Significant Byte) to file first.

The byte order of the length tags and all binary fields within
a datagram is always identical to the native byte order of the
computer that writes the data file. It is the responsibility of
the software that reads the file to perform byte swapping of all
multibyte numbers within a datagram if required. Byte swapping
is required whenever there is an apparent mismatch between the
head and the tail length tags. Hence, the two length tags may be
used to identify the byte order of the complete datagram.
The Intel processors allow a multibyte number to be located
at any RAM address. However, this may be different on other
processors; a short (2 byte) must be located at an even address,
a long (4 byte) and a float (4 byte) must be located at addresses
that can be divided by four. Hence, the numeric fields within a
datagram is specified with this in mind.
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Configuration datagram
All character strings are zero terminated.
struct ConfigurationDatagram {

DatagramHeader DgHeader // ”CON0”
ConfigurationHeader ConfigHeader;
ConfigurationTransducer Transducer[];
};

struct ConfigurationHeader
{

char SurveyName[128]; // ”Loch Ness”
char TransectName[128];
char SounderName[128]; // “ER60”
char version [30];
char spare [98];
long TransducerCount; // 1 to 7

};

struct ConfigurationTransducer {
char ChannelId[128]; // Channel identification
long BeamType; // 0 = Single, 1 = Split
float Frequency; // [Hz]
float Gain; // [dB] - See note below
float EquivalentBeamAngle; // [dB]
float BeamWidthAlongship; // [degree]
float BeamWidthAthwartship; // [degree]
float AngleSensitivityAlongship;
float AngleSensitivityAthwartship;
float AngleOffsetAlongship; // [degree]
float AngleOffsetAthwartship; // [degree]
float PosX; // future use
float PosY; // future use
float PosZ; // future use
float DirX; // future use
float DirY; // future use
float DirZ; // future use
float PulseLengthTable[5];

// Available pulse lengths for the
// channel [s]

char Spare1[8]; // future use
float GainTable[5];

// Gain for each pulse length in the
// PulseLengthTable [dB]

char Spare2[8]; // future use
float SaCorrectionTable[5];

// Sa correction for each pulse length in
// the PulseLengthTable [dB]

char Spare3[8];
char GPTSoftwareVersion [16];
char Spare4[28];
};

1 float Gain: The single gain parameter was used actively in
raw data files generated with software version 1.3. This was
before PulseLengthTable, GainTable and SaCorrectionTable
were introduced in software version 1.4 to enable gain and
Sa correction parameters for each pulse length.
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NMEA datagrams
The NMEA datagrams contain original NMEA 0183 input
sentences.
struct TextDatagram{

DatagramHeader DgHeader; // “NME0”
char Text[]; // ”$GPGLL,5713.213,N......”

};

The size of the datagram depends on the sentence length.
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Annotation datagrams
The annotation datagram contains comment text.
struct TextDatagram{

DatagramHeader DgHeader; // “TAG0”
char Text[]; // ”Dangerous wreck”

};

The text string is zero terminated. The size of the complete
datagram depends on the annotation length (maximum 80
characters).
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Sample datagram
The sample datagram contains data from just one transducer
channel. It can contain power sample data, or it can contain both
power and angle sample data.
struct SampleDatagram

{
DatagramHeaderDgHeader; // “RAW0”
short Channel; // Channel number
short Mode;

// Datatype: 1 = Power, 2 = Angle, 3 = Both
float TransducerDepth; // [m]
float Frequency; // [Hz]
float TransmitPower; // [W]
float PulseLength; // [seconds]
float BandWidth; // [Hz]
float SampleInterval; // [s]
float SoundVelocity; // [m/s]
float AbsorptionCoefficient; // [dB/m]
float Heave; // [m]
float Roll; // [degree]
float Pitch; // [degree]
float Temperature; // [deg C]
float Heading; // [degree]
short TransmitMode;

// 0 = Active, 1 = Passive
// 2 = Test, -1 = Unknown

char Spare[6];
long Offset; // First sample
long Count; // Number of samples
short Power[]; // Compressed format - See below!
short Angle[]; // See below!
};

1 Power: The power data contained in the sample datagram is
compressed. In order to restore the correct value(s), you
must decompress the value according to the equation below.

y = x
10 log(2)

256

where:
x = power value derived from the datagram
y = converted value (in dB)

2 Angle: The fore-and-aft (alongship) and athwartship
electrical angles are output as one 16-bit word. The
alongship angle is the most significant byte while the
athwartship angle is the least significant byte. Angle data is
expressed in 2’s complement format. The electrical angle
must be multiplied with the angle sensitivity to get the target
position relative to beam centre. Positive numbers denotes
the fore and starboard directions.
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Data subscriptions and remote control
The echo sounder implements the facility to subscribe to data and
control the echo sounder operation from a user developed remote
application. This enables you to write your own application
which controls the operations of the echo sounder (e.g. start/stop
pinging, change ping interval, and start/stop data recording).
From your application you can also subscribe to data from the
echo sounder. This means that you can ask the echo sounder to
continuously send various data (e.g. Depth data, Target Strength
data, and Integration data) to your application.

Figure 37 Data subscriptions

Client
application

(Echo sounder
or third party)

Subscriber parameter updates
(UDP / Binary)

Subscribed data updates
(UDP / Binary)

Commands and responses
(UDP / XML)

Echo sounder
server application

(CD010017A)

The communication between the echo sounder program and
your program is performed by exchanging UDP messages
via the LAN. Command and response messages are XML
based text messages. Subscribed data updates are binary data
structures, which must be decoded using information about the
data structure.

Topics

Data subscriptions overview on page 175
Request server information on page 176
Connecting to server on page 177
Keep connection alive on page 179
Issue commands on the server on page 180
Collecting data on page 183
Parameter management on page 187
Disconnecting from server on page 190
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Data subscriptions overview
The following is an overview of the process for data subscription
and remote control.
1 Request server information
2 Connect to server
3 Keep connection alive
4 Issue commands on server

• Subscription of data:
a Create data subscriptions
b Handle data
c Change data subscriptions
d Destroy data subscriptions

• Parameter management:
a Get parameter
b Set parameter
c Start parameter notifications
d Stop parameter notifications

5 Disconnecting from server
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Request server information
Before you connect to the server running the echo sounder
program, your client application must obtain information about
the server’s IP address and command port number.

RequestServerInfo

Send the following RequestServerInfo message to the specific IP
address of the server, or broadcast the message to receive server
information from all servers on the LAN. The message should
be send to the UDP port number found in the Local port field
on the Server page in the Remoting dialogue box in the server
application.
struct RequestServerInfo

{
char Header[4]; // ”RSI\0”
};

ServerInfo2

The server applications will respond to the requesting application
with a message containing information about the server
application. The content of the ServerInfo2 message is shown
below.
struct ServerInfo2

{
char Header[4]; // ”SI2\0”
char ApplicationType[64];
char ApplicationName[64];

// Name of the current application
char ApplicationDescription[128];

// Description of the current application
long ApplicationID;

// ID of the current application
long CommandPort;

// Port number to send commands to
long Mode;

// If the application is
// running against the local data source
// or a remote data source

char HostName[64];
// IP address of the computer the
// application is running on

};

CommandPort

The server UDP port number CommandPort must be used from
now on to send commands to the server application.
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Connecting to server
Before commands can be sent to the server application, the
client application must identify itself to the server application
by sending a connect command, ConnectRequest, to the server.
This connect command must contain user account and password
information.

ConnectRequest

The contents of the connect message is shown below.
struct ConnectRequest

{
char Header[4]; // ”CON\0”
char ClientInfo[1024];

// e.g. ”Name:Simrad;Password:\0”
};

Response

The server application will respond with a Response message
containing at least the client id if the connect command
succeeded, or an error if the connect command failed. The
contents of the various parts of a response message for a
successful connect command is shown below.
struct Response

{
char Header[4]; // ”RES\0”
char Request[4]; // ”CON/0”
char MsgControl[22]; // ”\0”
char MsgResponse[1400];

// Response text containing result of
// connection request

};

MsgResponse

The contents of the MsgResponse field consist of ResultCode and
Parameters.
ResultCode: Result of the operation. The following values can
be present:
• S_OK: operation was successful
• E_ACCESSDENIED: operation failed due to unknown account
or wrong password

• E_FAIL: operation failed due to an unspecified error
Parameters: Comma separated list of various name:value pairs
that may be present, only provided if the ConnectRequest is
successful.
• ClientID: identification of the current client, to be used in all
further communication with the server application

• AccessLevel: general access level for the current client
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A successful connection will for example provide a MsgResponse
containing:
ResultCode:S_OK,
Parameters:{ClientID:1,AccessLevel:1}\0

Connection failure

In case the connect command fails, the ResponseField will contain
a ResultInfo field.
ResultInfo: Text describing the failure
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Keep connection alive
Once the client application is connected to the server application
a two-way monitoring of the application and communication
”health” must be started. This means that both the client and the
server application must send an ”alive” message, AliveReport,
periodically (each second).

AliveReport

The content of the AliveReport message is shown below.
struct AliveReport

{
char Header[4]; // ”ALI\0”
char Info[1024]; // e.g. ”ClientID:1,SeqNo:1\0”

};

The Info field in an AliveReport message from the client to the
server may contain (example):
ClientID:1,SeqNo:1\0

SeqNo

The SeqNo part of the Info field shall contain the sequence
number of the next request message from the client to the server
(the sequence number shall start on 1). The server will use this to
detect if any messages from the client have been lost, if a loss is
detected, the server will issue a re-transmit request to the client.
The AliveReportDef message from the server to the client may
contain (for example):
SeqNo:1\0

Similar, the SeqNo part of the Info field shall contain the sequence
number of the next response message from the server to the
client. The client application can use this to detect if any message
from the server is lost, and may then issue a re-transmit request
to the server.
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Issue commands on the server
Once connected, the following messages are used to issue
commands.

Request

A Request message must be sent to the server application in order
to issue a command on one of the available command targets in
the server application. An example of the main elements of a
command request is shown below.
struct Request

{
char Header[4]; // ”REQ\0”
char MsgControl[22];

// Sequence no, Current msg no, Total msg no
char MsgRequest[1400];

// XML based command request
};

MsgControl

The MsgControl field consists of the following parts:
• Sequence number: incremented for each request message sent
to the server

• Current message: contains the current message in case a
request must be split into several UDP messages

• Total message: contains the total number of messages the
current request consists of

If the contents ofMsgControl is ”2,1,3\0” it means that the current
UDP message is the second request message sent from the client
to the server, and that the current message is message number 1
of a request that consists of a total of three UDP messages.

MsgRequest

The contents of theMsgRequest depend on the current command
target and will be described in detail later. For the moment it is
enough to say that the format of the request is XML based and
that the request must specify a command target, a method on the
command target and any input parameters relevant for the current
method. The general structure of a request is shown below.
<request>

<clientInfo>
<cid>clientid</cid>
<rid>requestid</rid>

</clientInfo>
<type>invokeMethod</type>
<targetComponent>xx</targetComponent>
<method>
<yy>

<zz></zz>
</yy>
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</method>
</request>

where:
clientid = client identification
requestid = request identification
xx = the name of the current command target
yy = the name of the current method
zz = any parameters of the current method

Response

The server application will respond with a Response message as
shown below.
struct Response

{
char Header[4]; // ”RES\0”
char Request[4]; // ”REQ/0”
char MsgControl[22];

// Sequence no, Current msg no, Total msg no
char MsgResponse[1400];

// XML based response text containing result
// of command request

};

The contents of the Response depend on the current command
target and will be described in detail later. For the moment it is
enough to say that the format of the response is XML based and
that the response contains the result, any error messages, and any
output parameters relevant for the current method. The general
structure of a response is shown below.
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<response>
<clientInfo>

<cid dt=”3”>clientid</cid>
<rid dt=”3”>requestid</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>
</detail>

</fault>
<yyResponse>

<zz dt=”3”></zz>
</yyResponse>

</response>

where:
clientid = client identification
requestid = request identification
error code = the result of the operation. 0 = OK
yy = the name of the current method
zz = any parameters of the current method

182 164692/C



Data formats

Collecting data
In order to collect echo sounder data from the server application,
commands must be sent to the RemoteDataServer component of
the server application. The following methods/commands are
available.
• Create data subscription
• Handling data
• Change data subscription
• Destroy data subscription
For all commands a Request message must be sent from the client
to the server - in the following sections only the contents of the
Request field of the Request will be described.
For all commands a Response message will be sent from the
server to the client - in the following sections only the contents of
the Response field of the Response will be described.

Create data subscriptions

The method part of the request shall be set to Subscribe. The
Subscribe method is defined with the following input parameters.
• RequestedPort: The local port on the client application that the
data should be sent to

• DataRequest: The actual specification of the subscription
An example of the contents of the Request field of a Subscribe
command to the RemoteDataServer is shown below:
<request>

<clientInfo>
<cid>1</cid>
<rid>1</rid>

</clientInfo>
<type>invokeMethod</type>
<targetComponent>RemoteDataServer
</targetComponent>
<method>

<Subscribe>
<requestedPort>12345</requestedPort>
<dataRequest>BottomDetection</dataRequest>
</Subscribe>

</method>
</request>

The server application will respond with a Response message.
The Subscribe method has the following output parameters:
• SubscriptionID: The identification of the current subscription
- can be used to differentiate between multiple subscriptions
on the same port

An example of the contents of the Response field of a Subscribe
command to the RemoteDataServer is shown below.
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<response>
<clientInfo>

<cid dt=”3”>1</cid>
<rid dt=”3”>1</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>
</detail>

</fault>
<SubscribeResponse>

<subscriptionID dt=”3”></subscriptionID >
</SubscribeResponse>

</response>

Handling data

Data from the RemoteDataServer are wrapped in a ProcessedData
structure.
struct ProcessedData

{
char Header[4]; // ”PRD\0”
long SeqNo;

// Sequence number of the current
// UDP message

long SubscriptionID;
// Identification of the current data

unsigned short CurrentMsg;
// Current message number

unsigned short TotalMsg;
// Total number of UDP messages

unsigned short NoOfBytes;
// Number of bytes in the following
// Data field

unsigned short Data[];
// Actual data

};

If the amount of data exceeds the limit of one UDP message, the
data will be split into multiple UDP messages. The TotalMsg
field contains the number of UDP messages for the current data,
this is identified with any number larger than 1. The CurrentMsg
field contains the current message number out of the total number
of messages.
The Data field shall be decoded according to the specified
output structure from the subscription described in section Data
subscription types on page 191.

Change data subscriptions

The method part of the request shall be set to ChangeSubscription.
The ChangeSubscription method has the following parameters.
• subscriptionID: The id of the subscription that should be
changed
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• dataRequest: The actual specification of the subscription.
This is described in the section Data subscription types on
page 191.

An example of the contents of the Request field of a
ChangeSubscription command to the RemoteDataServer is shown
below.
<request>

<clientInfo>
<cid>1</cid>
<rid>1</rid>

</clientInfo>
<type>invokeMethod</type>
<targetComponent>RemoteDataServer

</targetComponent>
<method>

<ChangeSubscription>
<subscriptionID>1</subscriptionID>
<dataRequest>BottomDetection</dataRequest>

</ChangeSubscription>
</method>

</request>

The server application will respond with a Response message.
The ChangeSubscription method does not have any output
parameters.
An example of the contents of the Response field of a
ChangeSubscription command to the RemoteDataServer is shown
below.
<response>

<clientInfo>
<cid dt=”3”>1</cid>
<rid dt=”3”>1</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>

</detail>
</fault>
<ChangeSubscriptionResponse>

</ChangeSusbcriptionResponse>
</response>

Destroy data subscriptions

The method part of the request shall be set to Unsubscribe. The
Unsubscribe method has the following parameters.
• subscriptionID: The identification of the subscription that shall
be closed

An example of the contents of the szRequest field of an
Unsubscribe command to the RemoteDataServer is shown below.
<request>

<clientInfo>
<cid>1</cid>
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<rid>1</rid>
</clientInfo>
<type>invokeMethod</type>
<targetComponent>RemoteDataServer

</targetComponent>
<method>

<Unsubscribe>
<subscriptionID>1</subscriptionID>
</Unsubscribe>

</method>
</request>

The server application will respond with a ResponseDef message.
The Unsubscribe method does not have any output parameters.
An example of the contents of the Response field of an
Unsubscribe command to the RemoteDataServer is shown below.
<response>

<clientInfo>
<cid dt=”3”>1</cid>
<rid dt=”3”>1</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>

</detail>
</fault>
<UnsubscribeResponse>

</UnsubscribeResponse>
</response>
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Parameter management
In order to set/get parameters in the server application, commands
must be sent to the ParameterServer component of the server
application. The following methods/commands are available:
• Get parameter value/attribute
• Set parameter value/attribute
• Subscribe on parameter value/attribute change notifications
• Unsubscribe parameter notifications

Get parameter value/attribute

The method part of the request shall be set to GetParameter.
The server application will respond with a Response message.

Input parameters

The GetParameter method has the following input parameters:
• ParamName: Full name of the current parameter
• Time: The time where the value should be read (only available
for some parameters). Use 0 if latest value is wanted.

An example of the contents of the Request field of a GetParameter
command to the ParameterServer is shown below.
<request>

<clientInfo>
<cid>1</cid>
<rid>28</rid>

</clientInfo>
<type>invokeMethod</type>
<targetComponent>

ParameterServer
</targetComponent>
<method>

<GetParameter>
<paramName>
RemoteCommandDispatcher/ClientTimeoutLimit
</paramName>
<time>0</time>

</GetParameter>
</method>

</request>

Output parameters

The GetParameter method has the following output parameters:
• Value: The value of the parameter
• Time: The time when the parameter was updated
An example of the contents of the Response field of a
GetParameter command to the ParameterServer is shown below.
<response>

<clientInfo>
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<cid dt=”3”>1</cid>
<rid dt=”3”>28</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>

</detail>
</fault>
<GetParameterResponse>

<paramValue>
<value>60</value>
<time>0</time>

<paramValue/>
<GetParameterResponse/>

</response>

Set parameter value/attribute

The method part of the request shall be set to SetParameter.
The server application will respond with a Response message.

Input parameters

The SetParameter method has the following input parameters:
• ParamName: Full name of the current parameter
• paramValue: The new value to update the parameter with
• paramType: The data type of the paramValue field
An example of the contents of the Request field of a SetParameter
command to the ParameterServer is shown below.
<request>

<clientInfo>
<cid>1</cid>
<rid>28</rid>

</clientInfo>
<type>invokeMethod</type>
<targetComponent>

ParameterServer
</targetComponent>
<method>

<SetParameter>
<paramName>
RemoteCommandDispatcher/ClientTimeoutLimit
</paramName>
<paramValue>60</paramValue>
<paramType>3</paramType>

</SetParameter>
</method>

</request>
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Output parameters

The SetParameter method does not have any output parameters.
An example of the contents of the Response field of a
SetParameter command to the ParameterServer is shown below.
<response>

<clientInfo>
<cid dt=”3”>1</cid>
<rid dt=”3”>28</rid>

</clientInfo>
<fault>

<detail>
<errorcode dt=”3”>0</errorcode>
</detail>

</fault>
</response>
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Disconnecting from server
The client application shall send a DisconnectRequestDef message
to the server application when the client is finished with its
operation against the server.
The parameters are:
• Header: DIS\0
• szClientInfo: Name:Simrad;Password:\0

190 164692/C



Data formats

Data subscription types
This section describes the available data subscriptions in the
echo sounder.
All data subscriptions require the ChannelID (channel identifier)
for the frequency channel from which the subscription data is
requested. A comma separated list of available identifiers can
be obtained using the ParameterServer component to get the
parameter TransceiverMgr Channels.
The data output will always start with a 64-bit integer time value,
which identifies the number of 100 nanoseconds intervals that has
elapsed since January 1, 1601. If a parameter is skipped in the
subscription input string it will be replaced by the default value.
The decoding of the subscription will be case insensitive. In the
output data to be received by external devices, the information
about the current structure length is given. From this information,
the number of elements in an array may be calculated.

Topics

Bottom detection on page 192
Target strength (TS) detection on page 193
Sample data on page 195
Echogram on page 197
Targets echogram on page 198
Integration on page 199
Targets integration on page 200
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Bottom detection
Subscription type string: BottomDetection.

Input

Parameters Range Default Unit

UpperDetectorLimit (0,20000) 0 m

LowerDetectorLimit (0,20000) 1000 m

BottomBackstep (-200,100) –50 dB

Output

struct StructBottomDepthHeader
{

DWORDLONG dlTime;
};

struct StructBottomDepthData
{

double dBottomDepth;
// detected bottom depth [meter]

double dReflectivity;
// bottom surface backscatter [dB]

double dVesselLogDistance;
// sailed distance [nmi]

};
struct StructBottomDepth

{
StructBottomDepthHeader BottomDepthHeader;
StructBottomDepthData BottomDepthData;

};

Example

Building a BottomDetection subscription string:
BottomDetection, ChannelID=<ChannelID>,
UpperDetectorLimit=3.0, LowerDetectorLimit=500.0,
BottomBackstep=-60.0
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Target strength (TS) detection
Subscription type string: TSDetection.

Input

Parameters Range Default Unit

sLayerType (Surface.
Bottom,
Pelagic)

Surface None

Range (0,20000) 10000 m

RangeStart (0,20000) 0 m

MinTSValue (–120,50) –50.0 dB

MinEchoLength (0,20) 0.8 None

MaxEchoLength (0,20) 1.8 None

MaxGainCompensation (0,12) 6.0 None

MaxPhaseDeviation (0,100) 8.0 Phase steps

Output

struct StructTSDataHeader
{
DWORDLONG dlTime;
};

struct StructEchoTrace
{
double Depth;

// Target depth [meter]
double TSComp;

// Compendated TS [dB]
double TSUncomp;

// Uncompensated TS [dB]
double AlongshipAngle;

// Alongship angle [deg]
double AthwartshipAngle;

// Athwartship angle [deg]
double sa;

// Sa value for target
};

struct StructTSDataBody
{
WORD NoOfEchoTraces;

// Number of targets accepted in ping
StructEchoTrace EchoTraceElement[100];
};

struct StructTSData
{
StructTSDataHeader TSDataHeader;
StructTSDataBody TSDataBody;
};
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Example

Building a TSDetection subscription string:
TSDetection, ChannelID=<ChannelID>,
LayerType=Surface, Range=200,
RangeStart=3, MinTSValue=-55,
MinEcholength=0.7, MaxEcholength=2.0,
MaxGainCompensation=6.0, MaxPhasedeviation=7.0
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Sample data
Subscription type string: SampleData.

Input

Parameters Range Default Unit

SampleDataType (Power, Angle, Sv, Sp,
Ss, TVG20, TBG40,
PowerAngle)

Power None

Range (0,20000) 100 m

RangeStart (0,20000) 0 m

Output for Power, Angle, Sv, Sp, Ss, TVG20 and
TVG40

struct StructSampleDataHeader
{
DWORDLONG dlTime;
};

struct StructSampleDataArray
{
short nSampleDataElement[30000];

// 16-bits sample in logarithmic format
};

struct StructSampleData
{
StructSampleDataHeader SampleDataHeader;
StructSampleDataArray SampleDataArray;
};

Output for PowerAngle

struct StructSampleDataHeader
{
DWORDLONG dlTime;
};

struct StructSamplePowerAngleArray
{
short nSampleDataElement[60000];

// Composite sample array for power
// and angle

};
struct StructSamplePowerAngleValues

{
int nPowerValues;

// Number of power samples
int nAngleValues;

// Number of angle values
};

struct StructSamplePowerAngle
{
StructSampleDataHeader SampleDataHeader;
StructSamplePowerAngleValues SamplePowerAngleValues;
StructSamplePowerAngleArray SamplePowerAngleArray;
};
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Example

Building an SampleData subscription string:
SampleData,ChannelID=<ChannelID>,
SampleDataType=Power, Range=100,
RangeStart=10
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Echogram
Subscription type string: Echogram.

Input

Parameters Range Default Unit

PixelCount (0,10000) 500 None

Range (0,20000) 100 m

RangeStart (0,20000) 0 m

TVGType (Pr, Sv,
Sp, TS,
SpAndTS)

Sv None

EchogramType (Surface,
Bottom,
Trawl)

Surface None

CompressionType (Mean, Peak) Mean None

ExpansionType (Interpolation,
Copy)

Interpolation None

Output

struct StructEchogramHeader
{

DWORDLONG dlTime;
};
struct StructEchogramArray
{

short nEchogramElement[30000];
// 16-bit logarithmic format

};
struct StructEchogram

{
StructEchogramHeader EchogramHeader;
StructEchogramArray EchogramArray;

};

Example

Building a Echogram subscription string:
Echogram, ChannelID=<ChannelID>,
PixelCount=500, Range=100, RangeStart=0,
TVGType=TS, EchogramType=Surface,
CompressionType=Mean, ExpansionType=Interpolation
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Targets echogram
Subscription type string: TargetsEchogram .
This subscription will only produce an echogram array containing
detected echo traces with their compensated TS values between
the transmit pulse and the bottom. Below bottom the selected
TVG type is used.

Input

Parameters Range Default Unit

PixelCount (0,10000) 500 None

Range (0,20000) 100 m

RangeStart (0,20000) 0 m

TVGType (TS, SP, Ts) Must be set None

EchogramType (Surface,
Bottom)

Surface None

MinTSValue (-120,50) –50 dB

MinEchoLength (0,20) 0.8 None

MaxEchoLength (0,20) 1.8 None

MaxGainCompensation (0,12) 6.0 dB

MaxPhaseDeviation (0,100) 8.0 Phase steps

Output

struct StructEchogramHeader
{

DWORDLONG dlTime;
};

struct StructEchogramArray
{

short nEchogramElement[30000];
};

struct StructEchogram
{

StructEchogramHeader EchogramHeader;
StructEchogramArray EchogramArray;

};

Example

Building a TargetsEchogram subscription string:
TargetsEchogram, ChannelID=<ChannelID>,
PixelCount=500, Range=100, RangeStart=0,
TVGType=TS, EchogramType=Surface, MinTSValue=-55.0,
MinEcholength=0.7, MaxEcholength=2.0,
MaxGainCompensation=6.0, MaxPhasedeviation=7.0
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Integration
Subscription type string: Integration.
The update of Sa will be enabled by setting the Integration State
to start. If the update parameter is set to Update Ping, the new Sa
value is received for every ping. If the Update Accumulate is set,
the Sa is received only when the Integration State changes to Stop.

Input

Parameters Range Default Unit

LayerType (Surface,
Bottom,
Pelagic)

Surface None

IntegrationState (Start, Stop) Start None

Update (UpdatePing,
UpdateAccumulate)

UpdatePing None

Range (0,20000) 100 m

RangeStart (0,20000) 10 m

Margin (0,200) 1 m

SvThreshold (–200,100) –100 dB

Output

struct StructIntegrationDataHeader
{

DWORDLONG dlTime;
};

struct StructIntegrationDataBody
{

double dSa;
// integrated value [m2/nmi2]

};
struct StructIntegrationData

{
StructIntegrationDataHeader IntegrationDataHeader;
StructIntegrationDataBody IntegrationDataBody;

};

Example

Building a Integration subscription string:
Integration, ChannelID=<ChannelID>,
State=Start, Update=UpdatePing,
Layertype=Surface, Range=100,
Rangestart=10, Margin=0.5, SvThreshold=-100.0
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Targets integration
Subscription type string: TargetsIntegration.
This is a composite subscription where TS detection and
integration parameters must be set. The Sa value is taken only
from the accepted single echo trace inside the range.

Input

Parameters Range Default Unit

sLayerType (Surface,
Bottom,
Pelagic)

Surface None

sIntegrationState (Start, Stop) Start None

Update (UpdatePing,
UpdateAccumulate)

UpdatePing None

Range (0,20000) 100 m

RangeStart (0,20000) 10 m

Margin (0,200) 1 m

SvThreshold (–200,100) –100 dB

MinTSValue (–120,50) –50 dB

MinEchoLength (0,20) 0.8 None

MaxEchoLength (0,20) 1.8 None

MaxGainCompensation (0,12) 6.0 dB

MaxPhaseDeviation (0,100) 8.0 Phase steps

Output

struct StructIntegrationDataHeader
{

DWORDLONG dlTime;
};

struct StructIntegrationDataBody
{

double dSa;
// integrated value from single echo
// trace [m2/nmi2]

};
struct StructIntegrationData

{
StructIntegrationDataHeader IntegrationDataHeader;
StructIntegrationDataBody IntegrationDataBody;

};
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Example

Building a TargetsIntegration subscription string:
TargetsIntegration, ChannelID=<ChannelID>,
State=Start, Layertype=Surface, Range=100,
Rangestart=10, Margin=0.5, SvThreshold=-100.0,
MinTSValue=-55.0, MinEcholength=0.7,
MaxEcholength=2.0, MaxGainCompensation=6.0,
MaxPhasedeviation=7.0
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Parameter descriptions
The ParameterServer component can be used to access
asynchronous and ping based parameters. The parameters can
be “read”, “set” or subscribed to. A subscription will notify only
when the parameter’s value is changed.
The following is a list of the most relevant parameters. The
parameter name must be used when working with parameters as
described in the Parameter Management section. Parameters
identified as “read only” (R/O) can not be set. Some of them, for
example sensor parameters, can be set, but the new value will
immediately be over-written if a live sensor is connected.

Related topics

Parameter management on page 187

Table 6 Ping based parameters

Description Parameter name R/O Range Unit

List of ChannelID’s TransceiverMgr/
Channels

Yes N/A -

Frequency TransceiverMgr/
<ChannelID>/
Frequency

Yes 1.000 to 1.000.000 Hz

Pulse length TransceiverMgr/
<ChannelID>/
PulseLength

No 0,000 to 0,065535 sec

Sample interval TransceiverMgr/
<ChannelID>/
SampleInterval

No 0,000010 to
0,065535

sec

Transmit power TransceiverMgr/
<ChannelID>/
TransmitPower

No 0 to 10.000 W

Absorption Coefficient TransceiverMgr/
<ChannelID>/
AbsorptionCofficient

Yes 0,0 to 0,3 dB/m

Sound velocity TransceiverMgr/
<ChannelID>/
SoundVelocity

No 1.400 to 1.700 m/s

Transducer name TransceiverMgr/
<ChannelID>/
TransducerName

Yes N/A -

Transducer depth TransceiverMgr/
<ChannelID>/
TransducerDepth

No 0 to 10.000 m

Equivalent beam angle TransceiverMgr/
<ChannelID>/
EquivalentBeamAngle

No –100 to 0 dB

Angle sensitivity alongship TransceiverMgr/
<ChannelID>/
AngleSensitivityAlongship

No 0 to 100 el.deg/mec.deg
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Table 6 Ping based parameters (cont’d.)

Description Parameter name R/O Range Unit

Angle sensitivity
athwartship

TransceiverMgr/
<ChannelID>/
AngleSensitivityAthwartship

No 0 to 100 el.deg/mec.deg

Beamwidth alongship TransceiverMgr/
<ChannelID>/
BeamWidthAlongship

No 0 to 100 deg

Beamwidth athwartship TransceiverMgr/
<ChannelID>/
BeamWidthAthwartship

No 0 to 100 deg

Angle offset alongship TransceiverMgr/
<ChannelID>/
AngleOffsetAlongship

No –10 to 10 deg

Angle offset athwartship TransceiverMgr/
<ChannelID>/
AngleOffsetAthwartship

No –10 to 10 deg

Gain TransceiverMgr/
<ChannelID>/
Gain

No 1 to 100 dB

Sa correction TransceiverMgr/
<ChannelID>/
SaCorrection

No –10 to 10 dB

Ping time TransceiverMgr/
PingTime

Yes 2E64 100 ns step

Vessel latitude TransceiverMgr/
Latitude

No –90 to 90 deg

Vessel longitude TransceiverMgr/
Longitude

No –180 to 180 deg

Vessel heave TransceiverMgr/
Heave

No –100 to 100 m

Vessel roll TransceiverMgr/
Roll

No –90 to 90 deg

Vessel pitch TransceiverMgr/
Pitch

No –90 to 90 deg

Vessel distance TransceiverMgr/
Distance

Yes 0 to 100.000 nmi

Noise estimate ProcessingMgr/
<ChannelID>/
ChannelProcessingCommon/
NoiseEstimate

Yes 0 to –200 dB

Table 7 Asynchronous parameters

Description Parameter name R/O Range Unit

Vessel speed OwnShip/
Speed

No 0 to 100 m/s

Vessel latitude OwnShip/
Latitude

No –90 to 90 deg
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Table 7 Asynchronous parameters (cont’d.)

Description Parameter name R/O Range Unit

Vessel longitude OwnShip/
Longitude

No –180 to 180 deg

Vessel heave OwnShip/
Heave

No –100 to 100 m

Vessel roll OwnShip/
Roll

No –90 to 90 deg

Vessel pitch OwnShip/
Pitch

No –90 to 90 deg

Vessel distance OwnShip/
VesselDistance

No 0 to 100.000 nmi

Environment temperature OwnShip/
EnvironmentData/
Temperature

No –5 to 50 deg

Environment salinity OwnShip/
EnvironmentData/
Salinity

No 0 to 0,01 –

Environment sound velocity OwnShip/
EnvironmentData/
SoundVelocity

No 1400 to 1700 m/s

Table 8 Operation mode parameters

Description Parameter name R/O Range Unit

Ping start/stop OperationControl/
OperationMode

No Last bit: 0 = Stop, 1 = Start

Ping rate mode AcousticDeviceSynchroniser/
SyncMode

No 1 = Interval, 2 = Maximum,
32 = Single step

Ping interval AcousticDeviceSynchroniser/
Interval

No Larger than 10 msec

Save raw data on/off AcousticDeviceSynchroniser/
SaveRawData

No 0 = Off, 1 = On
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NMEA telegram specifications
The NMEA telegrams supported by the Simrad ER60 Scientific
echo sounder are briefly described in this section. For detailed
information about the telegrams, refer to the official NMEA
documentation.

Topics

GGA Global positioning system fix data on page 205
GLL Geographical position latitude/longitude on page 206
HDG Heading, deviation and variation on page 206
HDM Heading, magnetic on page 206
HDT Heading, true on page 207
RMC Recommended minimum specific GNSS data on page 207
VHW Water speed and heading on page 207
VLW Dual ground/water distance on page 208
VTG Course over ground and Ground speed on page 208

GGA Global positioning system fix data
This telegram contains time, position and fix related data from a
global positioning system (GPS).
$--GGA,hhmmss.ss,llll.ll,a,yyyyy.yy,a,
x,zz,d.d,a.a,M,g.g,M,r.r,cccc*hh<CR><LF>

• GGA = telegram identifier
• hhmmss.ss = coordinated universal time (UTC) of position
• llll.ll,a = latitude nort/south, position in degrees, minutes and
hundredths. Characters N (North) or S (South) identifies the
bearing.

• yyyyy.yy,a = longitude east/west, position in degrees, minutes
and hundredths. Characters W (West) or E (East) identifies
the bearing.

• x = GPS quality indicator (refer to the NMEA standard for
further details)

• zz = number of satellites in use, 00 to 12, may be different
from the number in view

• d.d = horizontal dilution of precision
• a.a,M = altitude related to mean sea level (geoid) in meters
• g.g,M = geoidal separation in meters
• r.r = age of differential GPS data
• cccc = differential reference station identification, 0000 to
1023
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GLL Geographical position
latitude/longitude
This telegram is used to transfer latitude and longitude of vessel
position, time of position fix and status from a global positioning
system (GPS).
$--GLL,llll.ll,a,yyyyy.yy,a,
hhmmss.ss,A,a*hh<CR><LF>

• GLL = telegram identifier.
• llll.ll,a = latitude north/south, position in degrees, minutes and
hundredths. Characters N (North) or S (South) identifies the
bearing.

• yyyyy.yy,a = longitude east/west, position in degrees, minutes
and hundredths. Characters W (West) or E (East) identifies
the bearing.

• hhmmss.ss = coordinated universal time (UTC) of position.
• A = status, characters A (data valid) or V (data not valid) are
used.

• a = mode indicator.

HDG Heading, deviation and variation
This telegram contains the heading from a magnetic sensor,
which if corrected for deviation will produce magnetic heading,
which if offset by variation will provide true heading.
$--HDG,x.x,z.z,a,r.r,a*hh<CR><LF>

• HDG = telegram identifier
• x.x = magnetic sensor heading, degrees
• z.z,a = magnetic deviation, degrees east/west
• r.r,a = magnetic variation, degrees east/west
Heading conversion is performed as follows:
• To obtain magnetic heading: Add easterly deviation (E) to
magnetic sensor reading, or subtract westerly deviation (W)
from magnetic sensor reading.

• To obtain true heading: Add easterly variation (E) to magnetic
heading, or subtract westerly variation (W) from magnetic
heading.

HDM Heading, magnetic
This telegram contains vessel heading in degrees magnetic. The
telegram is no longer recommended for use in new designs. It is
often replaced by the HDG telegram.
$--HDM,x.x,M*hh<CR><LF>

• HDM = telegram identifier
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• x.x = heading in degrees, magnetic

HDT Heading, true
This telegram is used to transfer heading information from a gyro.
$--HDT,x.x,T*hh<CR><LF>

• HDT = telegram identifier
• x.x,T = heading, degrees true

RMC Recommended minimum specific
GNSS data
This telegram contains time, date, position, course and speed data
provided by a global navigation satellite system (GNSS) receiver.
$--RMC,hhmmss.ss,A,llll.ll,a,yyyyy.yy,a,
x.x,z.z,ddmmyy,r.r,a,a*hh<CR><LF>

• RMC = telegram identifier
• hhmmss.ss = coordinated universal time (UTC) of position fix
• A = status, characters A (data valid) or V (Navigation receiver
warning) are used.

• llll.ll,a = latitude nort/south. Characters N (North) or S (South)
identifies the bearing.

• yyyyy.yy.a = longitude east/west. Characters E (East) or W
(West) identifies the bearing.

• x.x = speed over ground, knots
• z.z = course over ground, degrees true
• ddmmyy = date
• r.r,a = magnetic variation, degrees east/west. Characters E
(East) orW (West) identifies the bearing.

• a = mode indicator

VHW Water speed and heading
This telegram contains the compass heading to which the vessel
points and the speed of the vessel relative to the water.
$--VHW,x.x,T,x.x,M,x.x,N,x.x,K*hh<CR><LF>

• VHW = telegram identifier
• x.x,T = heading, degrees true
• x.x,M = heading, degrees magnetic
• x.x,N = speed relative to water, knots, resolution 0.1
• x.x,K = speed relative to water, km/hr, resolution 0.1
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VLW Dual ground/water distance
This telegram contains the distance travelled relative to the water
and over the ground.
$--VLW,x.x,N,y.y,N,z.z,N,g.g,N*hh<CR><LF>

• VLW = telegram identifier
• x.x,N = total cumulative water distance, nautical miles.
• y.y,N = water distance since reset, nautical miles.
• z.z,N = total cumulative ground distance, nautical miles.
• g.g,N = ground distance since reset, nautical miles.

VTG Course over ground and Ground speed
This telegram contains the actual course and speed relative to
the ground.
$--VTG,x.x,T,y.y,M,z.z,N,g.g,K,a*hh<CR><LF>

• VTG = telegram identifier
• x.x,T = course over ground, degrees true
• y.y,M = course over ground, degrees magnetic
• z.z,N = speed over ground, knots, resolution 0.1
• g.g,K = speed over ground, km/hr, resolution 0.1
• a = mode indicator
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Proprietary telegram specifications
These proprietary telegrams supported by the Simrad ER60
Scientific echo sounder are briefly described in this section.

Topics

ATS Annotation on page 209
DBS Depth of trawl below surface on page 209
HFB Trawl headrope to footrope and bottom on page 209
TPT Trawl position true vessel on page 210
Ifremer trawl datagram on page 210
Kongsberg EM Attitude 1000 on page 212
Kongsberg EM Attitude 3000 on page 213
Sounder attitude on page 214

ATS Annotation
This proprietary Simrad telegram contains the free text to be used
as annotation on a datagram.
$??ATS,xxx<CR><LF>

• $?? = talker (mandatory)
• ATS = telegram identifier
• ,xxx = text string

DBS Depth of trawl below surface
This proprietary Simrad telegram contains the depth of the trawl
sensor.
@IIDBS,,,x.x,M,,<CR><LF>

• II = talker (mandatory)
• DBS = telegram identifier
• x.x,M = depth in meters (0 to 2000)

HFB Trawl headrope to footrope and
bottom
This proprietary Simrad telegram contains the distance from the
headrope to the footrope, and from the footrope to the bottom.
@IIHFB,x.x,M,y.y,M<CR><LF>

• II = talker (mandatory)
• HFB = telegram identifier
• x.x,M = distance from headrope to footrope, meters
• y.y, M = distance from footrope to bottom, meters
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TPT Trawl position true vessel
This proprietary Simrad telegram contains the true bearing and
water depth of the trawl sensor, as well as its distance from the
vessel.
@IITPT,x,M,y,P,z.z,M<CR><LF>

• II = talker (mandatory)
• TPT = telegram identifier
• x,M = horizontal range to the target.
• y,P = true bearing to the target.
• z.z,M = depth of trawl below the surface.

Ifremer trawl datagram
This proprietary telegram is used to receive trawl information
from Pacha and Scanmar trawl systems.

Data description Size Valid range Note
NMEA Header

Start 1 byte $
Code 1 byte P

Owner identification (Ifremer) 4 bytes IFM

Ifremer Header

Vessel 2 bytes TS (= Thalassa)

Talker CITE 4 bytes TEC

Date of telegram

Date 9 bytes dd/mm/yy,

Hour 13 bytes hh:mm:ss.sss,

Content

Header 6 bytes POGCH

Pacha status 3 bytes -3 to +1 Note 1

Scanmar status 3 bytes -3 to +1 Note 2

Trawl position

Indicator port beacon 2 bytes X, Note 3

Latitude 14 bytes S,DD,MM.MMMMM,

Longitude 15 bytes S,DDD,MM.MMMMM,

Horizontal distance 10 bytes +XXXXX.XX, (meters)

Bearing beacon/vessel 7 bytes +XX.XX, (degrees)

Immersion 9 bytes XXXXX.XX, (meters)

Indicator starboard beacon 2 bytes X, Note 4

Latitude 14 bytes S,DD,MM.MMMMM,

Longitude 15 bytes S,DDD,MM.MMMMM,

Horizontal distance 10 bytes +XXXXX.XX, (meters)

Bearing beacon/vessel 7 bytes +XX.XX, (degrees)

Depth 9 bytes XXXXX.XX, (meters)
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Data description Size Valid range Note
Trawl parameters The first byte “S” in each parameter is for “status”. See Note 5.

Depth 11 bytes S,XXXXX.XX, (meters) Note 5

Temperature 10 bytes SX,±XX.XXX, (degrees Celsius) Note 5

Headrope altitude 11 bytes S,XXXXX.XX, (meters) Note 5

Trawl speed / water alongship 8 bytes S,XX.XX, (meters /second) Note 5

Trawl speed / water athwartship 8 bytes S,XX.XX, (meters /second) Note 5

Footrope altitude 11 bytes S,XXXXX.XX, (meters) Note 5

Vertical opening 8 bytes S,XXX.X, (meters) Note 5

Horizontal opening 8 bytes S,XXX.X, (meters) Note 5

Distance between sensors #2 8 bytes S,XXX.X, (meters) Note 5

Distance between sensors #3 8 bytes S,XXX.X, (meters) Note 5

End of telegram
End 2 bytes <CR><LF>

The total number of bytes is 253.

Notes

1 Pacha status values:
• +0: Data Pacha ok
• +1: Data not updated
• -1: Default Pacha
• -2: Default communication Pacha
• -3: Default time synchronization unit

2 Scanmar status values:
• +0: data Scanmar ok
• +1: Data not updated
• -1: Default Scanmar
• -2: Default communication Scanmar
• -3: default time synchronization unit

3 Indicator port beacon values:
• 0: Port beacon available: Valid data
• 1: Port beacon available: Data not updated
• 3: Port beacon available: No sensor
• 9: Port beacon available

4 Indicator starboard beacon values:
• 0: Starboard beacon available: Valid data
• 1: Starboard beacon available: Data not updated
• 3: Starboard beacon available: No sensor
• 9: Starboard beacon available

5 Trawl parameter status byte:
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• 0: Parameter available: Valid data
• 1: Parameter available: Data not updated
• 2: Parameter available: Problem with acoustic
interference

• 3: Parameter available: No data
• 9: Parameter available

Kongsberg EM Attitude 1000
This proprietary Kongsberg binary telegram consists of a fixed
length 10-bytes message. It is defined as follows:
• Byte 1: Sync byte 1 = 00h
• Byte 2: Sync byte 2 = 90h
• Byte 3: Roll LSB
• Byte 4: Roll MSB
• Byte 5: Pitch LSB
• Byte 6: Pitch MSB
• Byte 7: Heave LSB
• Byte 8: Heave MSB
• Byte 9: Heading LSB
• Byte 10: Heading MSB
where LSB = least significant byte, MSB = most significant byte.
All data are in 2’s complement binary, with 0.01° resolution for
roll, pitch and heading, and 1 cm resolution for heave.
• Roll is positive with port side up with ±179.99° valid range
• Pitch is positive with bow up with ±179.99° valid range
• Heave is positive up with ±9.99 m valid range
• Heading is positive clockwise with 0 to 359.99° valid range
Non-valid data are assumed when a value is outside the valid
range.
You can define how roll is assumed to be measured, either
with respect to the horizontal plane (the Hippy 120 or TSS
convention), or to the plane tilted by the given pitch angle (i.e. as
a rotation angle around the pitch tilted forward pointing x-axis).
The latter convention (called Tate-Bryant in the POS/MV
documentation) is used inside the system in all data displays and
in logged data (a transformation is applied if the roll is given
with respect to the horizontal).
Note that heave is displayed and logged as positive downwards
(the sign is changed) including roll and pitch induced lever arm
translation to the system’s transmit transducer.
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This format was originally designed for use with the EM 950
and the EM 1000 multibeam echo sounders with the first
synchronisation byte always assumed to be zero. The sensor
manufacturers was then requested to include sensor status in the
format using the first synchronisation byte for this purpose. With
this additional information added, the datagram format is known
as “Kongsberg EM Attitude 3000”.

Kongsberg EM Attitude 3000
This proprietary Kongsberg binary telegram consists of a fixed
length 10-bytes message. It is defined as follows:
• Byte 1: Sync byte 1 = 00h, or Sensor status = 90h-AFh
• Byte 2: Sync byte 2 = 90h
• Byte 3: Roll LSB
• Byte 4: Roll MSB
• Byte 5: Pitch LSB
• Byte 6: Pitch MSB
• Byte 7: Heave LSB
• Byte 8: Heave MSB
• Byte 9: Heading LSB
• Byte 10: Heading MSB
where LSB = least significant byte, MSB = most significant byte.
All data are in 2’s complement binary, with 0.01° resolution for
roll, pitch and heading, and 1 cm resolution for heave.
• Roll is positive with port side up with ±179.99° valid range
• Pitch is positive with bow up with ±179.99° valid range
• Heave is positive up with ±9.99 m valid range
• Heading is positive clockwise with 0 to 359.99° valid range
Non-valid data are assumed when a value is outside the valid
range.
You can define how roll is assumed to be measured, either with
respect to the horizontal plane (theHippy 120 or TSS convention),
or to the plane tilted by the given pitch angle (i.e. as a rotation
angle around the pitch tilted forward pointing x-axis). The latter
convention (called Tate-Bryant in the POS/MV documentation)
is used inside the system in all data displays and in logged data
(a transformation is applied if the roll is given with respect to
the horizontal).
Note that heave is displayed and logged as positive downwards
(the sign is changed) including roll and pitch induced lever arm
translation to the system’s transmit transducer.
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This format has previously been used with the EM 950 and the
EM 1000 with the first synchronisation byte always assumed to
be zero (Datagram “Kongsberg EM Attitude 1000”). The sensor
manufacturers have been requested to include sensor status in
the format using the first synchronisation byte for this purpose.
It is thus assumed that:
• 90h in the first byte indicates a valid measurement with full
accuracy

• any value from 91h to 99h indicates valid data with reduced
accuracy (decreasing accuracy with increasing number)

• any value from 9Ah to 9Fh indicates non-valid data but normal
operation (for example configuration or calibration mode)

• and any value from A0h to AFh indicates a sensor error status

Sounder attitude
The Sounder attitude telegram protocol may be the most common
interface for heave, roll and pitch compensation. When you
select this protocol, the number of sensor variables is fixed, and
there is no token associated with it. However, baud rate and
output rate may be adjusted to fit your needs. The format is based
on ASCII characters, the datagrams have fixed length, and it is
terminated with a carriage return and line feed.
Format:
aabbbb shhhhxsrrrr spppp<CR><LF>

• aa = Sway; 2 characters hex number with sway acceleration,
in 0.03835 m/ss units

• bbbb = Heave; 4 characters hex number with heave
acceleration, in 0.000625 m/ss units

• s = 1 character with a [space] value if positive, or [-] if negative
• hhhh = Heave: 4 characters decimal number with heave
position in centimetres, positive up

• x = Status character, check the comments below.
• s = 1 character with a [space] value if positive, or [-] if negative
• rrrr = Roll: 4 character decimal number with roll angle in
hundreds of a degree

• s = 1 character with a [space] value if positive, or [-] if negative
• pppp = Pitch: 4 character decimal number with pitch angle
in hundres of a degree

The definition of the attitude angles in this format is different
from the Euler angles definition used elsewhere. The difference
appears in the roll angle, where:
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roll arcsin [ sin (roll ) cos (pitch ) ]=echosounder euler euler

The various status characters have the following meanings:
• U = Unaided mode and stable data. The sensor operates
without external input data.

• u = Unaided mode, but unstable data. The sensor is without
external input data, but the data from the sensor is unstable. A
probable cause for this is the lack of alignment after the sensor
has been switched on restarted. The alignment period from a
power recycle is normally approximately five minutes.

• G = Speed aided mode and stable data. The sensor operates
with external input of speed data.

• g = Speed aided mode, but unstable data. The sensor operates
with external input of speed data, but the data from the sensor
is unstable. A probable cause for this is the lack of alignment
after the sensor has been switched on restarted, or a failure
in the speed data input.

• H = Heading aided mode and stable data. The sensor operates
with external input of heading data.

• h = Heading aided mode, but unstable data. The sensor
operates with external input of heading data, but the data from
the sensor is unstable. A probable cause for this is the lack of
alignment after the sensor has been switched on restarted, or a
failure in the heading data input.

• F = Full aided mode and stable data. The sensor operates with
external input of both speed and heading data.

• f = Full aided mode, but unstable data. The sensor operates
with external input of heading and speed data, but the data
from the sensor is unstable. A probable cause for this is
the lack of alignment after the sensor has been switched on
restarted, or a failure in the heading and/or speed data input.)
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Help, 56
Install, 54
Operation, 53
Options, 54
Output, 55
short-cut
Colour Scale, 59–60
Depth, 57
Echogram, 58
Scope, 59
Single Target
Histogram, 57
Single Target
Position, 57

View, 53
Window, 55

Menu system, 52
Minimum
depth
how to define, 14

Mode
communication, 158
operational status, 124

Modify
user properties, 164

Motion
dialogue, 117
input, 117

Multiplexer
connection
procedure, 37

selection, 157

N
Name
data source, 80
setting file, 114, 146

Navigation
dialogue, 118

Network
IP address, 157

New Channel
function, 122

New Layer
function, 123

NMEA
annotation
input, 66

sentence
distance, 93, 104, 121
position, 119
speed, 120

Noise measurements
procedure, 32

Normal Operation
dialogue, 124

Number

218 164692/C



Index

annotation
identification, 66
of colours, 76

Numerical
view, 51

Numerical View
dialogue, 126

O
Observer
user, 163

Open All
function, 127

Operation
menu, 53

Operator
user, 163

Options
menu, 54

Output
EK500 datagrams, 97
menu, 55

P
Palette
presentation, 76

Parity
serial line
setup, 147

Passive
operational status, 124

Password
change, 164
log in, 115

Path
setting file, 114

Pelagic
layer properties, 113

Ping
Calculation Interval, 71
Horizontal Axis, 110

Ping Control
dialogue, 128

Ping rate
modes, 128

Pinging
start/stop, 128

Pitch
attitude telegram, 212–213

Pixel
adjustment
Echogram, 88

Playback
raw data
how to, 17

Playback file
add, 144

loop, 144
remove, 144

Port
depth output, 83
local
(LAN port setup), 111
(Remoting), 140

remote
(Ethernet Output), 98
(Remoting), 142

Port Management
dialogue, 130

Port Monitor
dialogue, 133

Position
geographical
telegram, 206

GNSS data, 207
input, 119
system fixed data
telegram, 205

Power
off
procedure, 12

on
procedure, 11

Presentation
colour scale, 76
colours, 76
palette, 76

Print
dialogue, 135

Print Preview
dialogue, 136

Procedure
calibration, 19
channel disconnect, 15
channel installation, 15
connect multiplexer, 37
data recording, 16
data replay, 17
define maximum depth, 14
define minimum depth, 14
echogram channel
disconnect, 15
echogram channel
installation, 15
echogram range, 13
echogram settings, 13
noise measurements, 32
power off, 12
power on, 11
raw data recording, 16
raw data replay, 17
set up transceiver
channels, 11, 37
vertical resolution, 13

Protocol

sentence
motion, 117

Pulse duration
operational status, 124

R
Range
echogram
how to change, 13

layer properties, 112
raw data recording, 102
tab
(EK500 Datagram), 92

Raw data
how to record, 16
how to replay, 17
recording
about, 16

Recording
about, 16
raw data
how to, 16

Remote
IP address
(Ethernet Output), 98
(LAN port setup), 111
(Remoting), 142

local
(LAN port setup), 111

port
(Ethernet Output), 98
(Remoting), 142

Remoting
dialogue, 139

Remove
playback file, 144
user, 164

Replay
dialogue, 144
raw data
how to, 17

Replay file
add, 144
loop, 145
remove, 144

Resolution
Histogram, 109
vertical
how to change, 13

RMC
telegram, 207

Roll
attitude telegram, 212–213

S
Salinity
water
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input, 94
Sample data
EK500 datagram, 91

Sample interval
operational status, 124

Save
raw data, 102

Save Settings
dialogue, 146

Scale lines
Echogram, 86

Scope
short-cut menu, 59
view, 49

Select
data source, 81

Serial line
setup, 147

Serial Port Setup
dialogue, 147

Server
Remoting, 140

Settings
echogram
how to change, 13

Setup
depth output
communication port, 83

Short-cut menu
Colour Scale, 59–60
Depth, 57
Echogram, 58
Scope, 59
Single Target
Histogram, 57
Single Target Position, 57

Short-cut menus, 57
Simrad
user, 163

Single ping
transmission, 128

Single step
ping rate, 128

Single Target Detection
dialogue, 148

Single target histogram
view, 47

Single Target Histogram
short-cut menu, 57

Single target position
view, 46

Single Target Position
short-cut menu, 57

Software
version, 9

Sound speed
input, 94

Sounder

attitude datagram, 214
Speed
input, 120
manual, 120

Speed data
ground referenced
telegram, 208

water referenced, 207
Start
pinging, 128

Start Relative Bottom
layer properties, 112

Start Relative Surface
layer properties, 112

Status bar
content, 43
enable, 43, 150
function, 150
location, 43

Stop
pinging, 128

Surface
layer properties, 113
reference
(Echogram), 85

Surface Range
dialogue, 151
EK500 datagram, 92

Sv threshold
layer properties, 113

T
Talker ID
depth output, 83

Targets Integration
layer properties, 113

Telegram
depth output, 83

Telegram code
Annotation, 209
DBS, 209
EM Attitude 1000, 212
EM Attitude 3000, 213
GGA, 205
GLL, 206
HDG, 206
HDM, 206
HDT, 207
HFB, 209
Ifremer, 210
RMC, 207
Sounder attitude, 214
TPT, 210
VHW, 207
VLW, 208
VTG, 208

Telegram name

Annotation, 209
Course over ground and
Ground speed, 208
Depth of trawl below
surface, 209
Dual ground/water
distance, 208
Geographical position
latitude/longitude, 206
Global positioning
system fix data, 205
Heading, deviation and
variation, 206
Heading, magnetic, 206
Heading, true, 207
Ifremer trawl datagram, 210
Kongsberg EM Attitude
1000, 212
Kongsberg EM Attitude
3000, 213
Recommended
minimum specific
GNSS data, 207
Sounder attitude, 214
Trawl headrope to
footrope and bottom, 209
Trawl position true
vessel, 210
Water speed and
heading, 207

Temperature
water
input, 94

Test
operational status, 124

Text
annotation, 66
echogram, 87

event annotation
input, 66

Ticks
echogram, 87

Tile
function, 153

Time
Calculation Interval, 70
Horizontal Axis, 110

Timer
event annotation
input, 66

Tool bar
Easy Operation
enable, 154

function, 154
Normal Operation
enable, 154

Toolbar
easy operation, 42
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location, 42
normal operation, 42

Tooltip
dialogue, 155

TPT
telegram, 210

Transceiver
channels
set up, 11, 37

information, 157
IP address, 157
name, 157
software version, 157

Transceiver Installation
dialogue, 156

Transducer
installation depth, 124
multiplexer, 157
parameters, 157
selection, 157

Transducer Parameters
dialogue, 159

Transmit Power
operational status, 124

Trawl
bottom
telegram, 209

depth, 210
telegram, 209

dialogue, 160
distance
manual, 161

footrope
telegram, 209

headrope
telegram, 209

Ifremer datagram, 210
input, 160, 164
opening
manual, 161

range, 210
system, 160, 164
true bearing
telegram, 210

Trawl lines
Echogram, 86

Tuples, 106
Type
tab
(Echogram), 85

U
UDP
port number
(Ethernet Output), 98

User
rights, 163

User name
data source, 80
log in, 115

User Properties
dialogue, 162

Users and Passwords
dialogue, 163

V
Version
software, 9

Vertical
marker
echogram, 87

resolution
how to change, 13

Vessel distance
raw data recording, 102

VHW
telegram, 207

View
menu, 53

VLW
telegram, 208

VTG
telegram, 208

W
Warnings
dialogue, 165

White line
Echogram, 86

Window
Colour scale, 50
depth, 45
Echogram, 48
menu, 55
Numerical, 51
Scope, 49
Single target histogram, 47
Single target position, 46
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